mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
3d85c3ec65
* gnu/packages/patches/pciutils-hurd-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/pciutils.scm (pciutils)[arguments]: Add 'apply-hurd-patch' phase when (hurd-target?) is true. [inputs]: Add "hurd-patch" entry when (hurd-target?) is true.
23 lines
677 B
Diff
23 lines
677 B
Diff
Fix a build error on GNU/Hurd for pciutils 3.7.0.
|
|
|
|
commit 053cf6c8b2acafadf828912828336d90fe9b8696
|
|
Author: Martin Mares <mj@ucw.cz>
|
|
Date: Sun May 31 11:53:28 2020 +0200
|
|
|
|
HURD backend should compile again
|
|
|
|
Fixes a bug introduced by commit 82c06b47dea5a38075ce9d56f743360bc47b4c78.
|
|
|
|
diff --git a/lib/hurd.c b/lib/hurd.c
|
|
index 7b3b2ae..ccd92f6 100644
|
|
--- a/lib/hurd.c
|
|
+++ b/lib/hurd.c
|
|
@@ -307,7 +307,6 @@ hurd_fill_regions(struct pci_dev *d)
|
|
d->base_addr[i] |= regions[i].is_64 << 2;
|
|
d->base_addr[i] |= regions[i].is_prefetchable << 3;
|
|
|
|
- if (flags & PCI_FILL_SIZES)
|
|
- d->size[i] = regions[i].size;
|
|
+ d->size[i] = regions[i].size;
|
|
}
|
|
}
|