mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
a6b9ebc2fc
* gnu/packages/maths.scm (combinatorial-blas): New variable. * gnu/packages/patches/combinatorial-blas-awpm.patch, gnu/packages/patches/combinatorial-blas-io-fix.patch: New files * gnu/local.mk(dist_patch_DATA): Add them.
14 lines
486 B
Diff
14 lines
486 B
Diff
IO not appropriate in the context of a sorting routine, and in any case the
|
|
proper headers are not included, so gcc emits an undefined symbol error.
|
|
Remove the "printf" statement.
|
|
|
|
--- CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
|
|
+++ CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
|
|
@@ -142,7 +142,6 @@
|
|
}
|
|
if ( (a[nmax]==a[nmin]) && (ctr==0) )
|
|
{
|
|
- printf("All the numbers are identical, the list is sorted\n");
|
|
return;
|
|
}
|
|
|