mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
51735eac1c
Enable the python bindings and switch to the meson build system that handles the python bindings better than the Makefile build system here. * gnu/packages/patches/dtc-meson-cell-overflow.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (dtc): Update to 1.7.0. [build-system]: Switch to the meson-build-system. [arguments]: Remove #:make-flags. Add a new 'preparations phase. Do not edit the Makefile in the 'patch-pkg-config phase. Remove the 'configure phase. Change-Id: Ie61c920829ab3a8c32f4924c694dba6bda807711 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
32 lines
1.4 KiB
Diff
32 lines
1.4 KiB
Diff
Taken from upstream:
|
|
https://git.kernel.org/pub/scm/utils/dtc/dtc.git/commit/?id=32174a66efa4ad19fc6a2a6422e4af2ae4f055cb
|
|
|
|
From 32174a66efa4ad19fc6a2a6422e4af2ae4f055cb Mon Sep 17 00:00:00 2001
|
|
From: David Gibson <david@gibson.dropbear.id.au>
|
|
Date: Tue, 28 Feb 2023 10:33:58 +1100
|
|
Subject: [PATCH] meson: Fix cell overflow tests when running from meson
|
|
|
|
Because meson always builds out-of-tree we need to reference things in the
|
|
original source tree via $SRCDIR from run_tests.sh. We forgot a couple of
|
|
cases for the cell overflow tests. Fix them.
|
|
|
|
Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
|
|
---
|
|
tests/run_tests.sh | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tests/run_tests.sh b/tests/run_tests.sh
|
|
index 91350ad3..f899d8cb 100755
|
|
--- a/tests/run_tests.sh
|
|
+++ b/tests/run_tests.sh
|
|
@@ -519,8 +519,8 @@ libfdt_tests () {
|
|
check_tests "$SRCDIR/phandle-args-overflow.dts" clocks_property
|
|
|
|
## https://github.com/dgibson/dtc/issues/74
|
|
- run_dtc_test -I dts -O dtb -o cell-overflow-results.test.dtb cell-overflow-results.dts
|
|
- run_dtc_test -I dts -O dtb -o cell-overflow.test.dtb cell-overflow.dts
|
|
+ run_dtc_test -I dts -O dtb -o cell-overflow-results.test.dtb "$SRCDIR/cell-overflow-results.dts"
|
|
+ run_dtc_test -I dts -O dtb -o cell-overflow.test.dtb "$SRCDIR/cell-overflow.dts"
|
|
run_test dtbs_equal_ordered cell-overflow.test.dtb cell-overflow-results.test.dtb
|
|
|
|
# check full tests
|