mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
82c43b276d
* gnu/packages/patches/linux-libre-infodocs-target.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/linux.scm (linux-libre-6.0-source, linux-libre-5.15-source) (linux-libre-5.10-source): Apply above patch. (doc-supported?): New procedure. (make-linux-libre) [DOC-SUPPORTED?]: Add new patch in the default patches used. Add a BUILD-DOC? argument. (make-linux-libre*): Add a BUILD-DOC? argument. Validate BUILD-DOC? for supported VERSION. [arguments]: Conditionally add the build-doc and install-doc phases. [native-inputs]: Conditionally add fontconfig, graphviz, python-wrapper, python-sphinx, texinfo and which.
88 lines
3.2 KiB
Diff
88 lines
3.2 KiB
Diff
Upstream status: https://marc.info/?l=linux-doc&m=166861669723994&w=2
|
|
|
|
From 7edb5b278ee383ff9bed525329b2cdbe22317bf2 Mon Sep 17 00:00:00 2001
|
|
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
|
Date: Mon, 14 Nov 2022 22:51:11 -0500
|
|
Subject: [PATCH] doc: add texinfodocs and infodocs targets
|
|
|
|
Sphinx supports generating Texinfo sources and Info documentation,
|
|
which can be navigated easily and is convenient to search (via the
|
|
indexed nodes or anchors, for example).
|
|
|
|
This change also causes the html output to appear under its own output
|
|
sub-directory, which makes it easier to install, since it's clean from
|
|
.doctrees or other output formats.
|
|
|
|
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
|
---
|
|
Documentation/Makefile | 13 ++++++++++++-
|
|
Documentation/userspace-api/media/Makefile | 3 ++-
|
|
Makefile | 2 +-
|
|
3 files changed, 15 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Documentation/Makefile b/Documentation/Makefile
|
|
index 64d44c1ecad3..bd8dac560633 100644
|
|
--- a/Documentation/Makefile
|
|
+++ b/Documentation/Makefile
|
|
@@ -93,7 +93,16 @@ quiet_cmd_sphinx = SPHINX $@ --> file://$(abspath $(BUILDDIR)/$3/$4)
|
|
|
|
htmldocs:
|
|
@$(srctree)/scripts/sphinx-pre-install --version-check
|
|
- @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),,$(var)))
|
|
+ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,html,$(var),html,$(var)))
|
|
+
|
|
+texinfodocs:
|
|
+ @$(srctree)/scripts/sphinx-pre-install --version-check
|
|
+ @+$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,texinfo,$(var),texinfo,$(var)))
|
|
+
|
|
+# Note: the 'info' Make target is generated by sphinx itself when
|
|
+# running the texinfodocs target define above.
|
|
+infodocs: texinfodocs
|
|
+ $(MAKE) -C $(BUILDDIR)/texinfo info
|
|
|
|
linkcheckdocs:
|
|
@$(foreach var,$(SPHINXDIRS),$(call loop_cmd,sphinx,linkcheck,$(var),,$(var)))
|
|
@@ -143,6 +152,8 @@ cleandocs:
|
|
dochelp:
|
|
@echo ' Linux kernel internal documentation in different formats from ReST:'
|
|
@echo ' htmldocs - HTML'
|
|
+ @echo ' texinfodocs - Texinfo'
|
|
+ @echo ' infodocs - Info'
|
|
@echo ' latexdocs - LaTeX'
|
|
@echo ' pdfdocs - PDF'
|
|
@echo ' epubdocs - EPUB'
|
|
diff --git a/Documentation/userspace-api/media/Makefile b/Documentation/userspace-api/media/Makefile
|
|
index 00922aa7efde..3d8aaf5c253b 100644
|
|
--- a/Documentation/userspace-api/media/Makefile
|
|
+++ b/Documentation/userspace-api/media/Makefile
|
|
@@ -47,10 +47,11 @@ $(BUILDDIR)/lirc.h.rst: ${UAPI}/lirc.h ${PARSER} $(SRC_DIR)/lirc.h.rst.exception
|
|
|
|
# Media build rules
|
|
|
|
-.PHONY: all html epub xml latex
|
|
+.PHONY: all html texinfo epub xml latex
|
|
|
|
all: $(IMGDOT) $(BUILDDIR) ${TARGETS}
|
|
html: all
|
|
+texinfo: all
|
|
epub: all
|
|
xml: all
|
|
latex: $(IMGPDF) all
|
|
diff --git a/Makefile b/Makefile
|
|
index 58cd4f5e1c3a..b3266c408b6c 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1785,7 +1785,7 @@ $(help-board-dirs): help-%:
|
|
# Documentation targets
|
|
# ---------------------------------------------------------------------------
|
|
DOC_TARGETS := xmldocs latexdocs pdfdocs htmldocs epubdocs cleandocs \
|
|
- linkcheckdocs dochelp refcheckdocs
|
|
+ linkcheckdocs dochelp refcheckdocs texinfodocs infodocs
|
|
PHONY += $(DOC_TARGETS)
|
|
$(DOC_TARGETS):
|
|
$(Q)$(MAKE) $(build)=Documentation $@
|
|
|
|
base-commit: 81e7cfa3a9eb4ba6993a9c71772fdab21bc5d870
|
|
--
|
|
2.38.1
|
|
|