guix/gnu/packages/patches/python-pyreadstat-link-libiconv.patch
Troy Figiel 185ebc01f6
gnu: Add python-pyreadstat.
* gnu/packages/patches/python-pyreadstat-link-libiconv.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/statistics.scm (python-pyreadstat): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Change-Id: I361df91487412e4bfd26fb728a6999752e6343e5
2024-01-09 10:19:43 +01:00

15 lines
384 B
Diff

To ensure libiconv can be found by Guix, we need to link the library.
--- a/setup.py
+++ b/setup.py
@@ -81,8 +81,7 @@ else:
libraries.extend(["m", "z"])
_platform = sys.platform
# Mac: iconv needs to be linked statically
- if _platform.lower().startswith("darwin"):
- libraries.append("iconv")
+ libraries.append("iconv")
# Extensions
sources.sort()