guix/gnu/packages/patches/telegram-desktop-unbundle-gsl.patch
dan 2b6006fc50
gnu: telegram-desktop: Update to 5.5.5.
* gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch: Update patch file to match upstream changes.
* gnu/packages/patches/webrtc-for-telegram-desktop-unbundle-libsrtp.patch: Update patch file to match upstream changes.
* gnu/packages/patches/telegram-desktop-unbundle-cppgir.patch: New file.
* gnu/packages/patches/telegram-desktop-unbundle-gsl.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register them.
* gnu/packages/telegram.scm:
(libyuv-for-telegram-desktop, cmake-helpers-for-telegram-desktop)
(codegen-for-telegram-desktop, lib-base-for-telegram-desktop)
(lib-crl-for-telegram-desktop, lib-lottie-for-telegram-desktop)
(lib-qr-for-telegram-desktop, lib-storage-for-telegram-desktop)
(lib-tl-for-telegram-desktop, lib-webrtc-for-telegram-desktop)
(tgcalls-for-telegram-desktop, webrtc-for-telegram-desktop): Bump to submodule checkout.
(cmake-helpers-for-telegram-desktop)[origin]: Add patches to unbundle gsl and cppgir.
(libprisma-for-telegram-desktop): Use %telegram-version.
(telegram-desktop): Update to 5.5.5.
[:configure-flags]: Add disable jemalloc flag.
[#:phases]<unpack-additional-sources>: Add libprisma-for-telegram-desktop.
<patch-gir-ignore-paths>: New phase.
<use-system-xdg-desktop-portal>: New phase.
<patch-libwebview>: New phase.
[native-inputs]: Add cpp-ada-url-parser, gobject-introspection and xdg-desktop-portal.
[inputs]: Add boost, cppgir-for-telegram-desktop, expected-lite and remove jemalloc.

Change-Id: I0ea3ea5a3e416a9d5b2b5b7b55ca1af679bc3d38
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
2024-09-26 14:21:17 +09:00

31 lines
1 KiB
Diff

From a3ac6df0441b4caca28b1df87febc420e18942ce Mon Sep 17 00:00:00 2001
From: Zephyr Lykos <git@mochaa.ws>
Date: Mon, 23 Oct 2023 15:55:24 +0800
Subject: [PATCH] Revert "Force usage of GSL fork because of a libstdc++ bug."
This reverts commit 982546b169df3d479e6511425870327559b38a89.
<https://github.com/microsoft/GSL/commit/e64c97fc2cfc11992098bb38eda932de275e3f4d>
---
external/gsl/CMakeLists.txt | 2 --
1 file changed, 2 deletions(-)
diff --git a/external/gsl/CMakeLists.txt b/external/gsl/CMakeLists.txt
index 8eaf19c5..344f9488 100644
--- a/external/gsl/CMakeLists.txt
+++ b/external/gsl/CMakeLists.txt
@@ -7,7 +7,6 @@
add_library(external_gsl INTERFACE IMPORTED GLOBAL)
add_library(desktop-app::external_gsl ALIAS external_gsl)
-#[[
if (DESKTOP_APP_USE_PACKAGED)
if (DESKTOP_APP_USE_PACKAGED_LAZY)
find_package(Microsoft.GSL 4.0.0 QUIET)
@@ -20,7 +19,6 @@ if (DESKTOP_APP_USE_PACKAGED)
return()
endif()
endif()
-]]
# https://gitlab.kitware.com/cmake/cmake/-/issues/25222
if (NOT EXISTS ${third_party_loc}/GSL/include)