mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
1b84d8ef34
* gnu/packages/patches/ghc-haddock-api-fix-haddock.patch: New file. * gnu/local.mk: Add it. * gnu/packages/haskell-xyz.scm (ghc-haddock-api): Update to 2.22.0. [source]: Use the new patch. [arguments]: Change the 'update-constraints' phase to allow newer versions of 'QuickCheck' and 'hspec'.
54 lines
2.2 KiB
Diff
54 lines
2.2 KiB
Diff
This patch is taken from upstream. It fixes documentation generation.
|
|
The patch has been lightly adapted to apply to the release tarball, but
|
|
the commit message was left untouched, so it refers to some changes not
|
|
included in the patch.
|
|
|
|
From 0d9a81e20238a6b72f9f5c005f1f7e9cf05f6fb9 Mon Sep 17 00:00:00 2001
|
|
From: Alec Theriault <alec.theriault@gmail.com>
|
|
Date: Sat, 27 Oct 2018 10:05:04 -0700
|
|
Subject: [PATCH] Fix documentation in `haddock-api` (#957)
|
|
|
|
* Fix misplaced Haddocks in Haddock itself
|
|
|
|
Haddock should be able to generate documentation for 'haddock-api'
|
|
again.
|
|
|
|
* Make CI check that documentation can be built.
|
|
|
|
* Add back a doc that is OK
|
|
---
|
|
.travis.yml | 3 +++
|
|
haddock-api/src/Haddock/Backends/LaTeX.hs | 10 +++++-----
|
|
2 files changed, 8 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/src/Haddock/Backends/LaTeX.hs b/src/Haddock/Backends/LaTeX.hs
|
|
index 4e0e6eba..613c6deb 100644
|
|
--- a/src/Haddock/Backends/LaTeX.hs
|
|
+++ b/src/Haddock/Backends/LaTeX.hs
|
|
@@ -243,8 +243,8 @@ ppDocGroup lev doc = sec lev <> braces doc
|
|
|
|
-- | Given a declaration, extract out the names being declared
|
|
declNames :: LHsDecl DocNameI
|
|
- -> ( LaTeX -- ^ to print before each name in an export list
|
|
- , [DocName] -- ^ names being declared
|
|
+ -> ( LaTeX -- to print before each name in an export list
|
|
+ , [DocName] -- names being declared
|
|
)
|
|
declNames (L _ decl) = case decl of
|
|
TyClD _ d -> (empty, [tcdName d])
|
|
@@ -444,9 +444,9 @@ ppLPatSig doc docnames ty unicode
|
|
-- arguments as needed.
|
|
ppTypeOrFunSig :: HsType DocNameI
|
|
-> DocForDecl DocName -- ^ documentation
|
|
- -> ( LaTeX -- ^ first-line (no-argument docs only)
|
|
- , LaTeX -- ^ first-line (argument docs only)
|
|
- , LaTeX -- ^ type prefix (argument docs only)
|
|
+ -> ( LaTeX -- first-line (no-argument docs only)
|
|
+ , LaTeX -- first-line (argument docs only)
|
|
+ , LaTeX -- type prefix (argument docs only)
|
|
)
|
|
-> Bool -- ^ unicode
|
|
-> LaTeX
|
|
--
|
|
2.23.0
|
|
|