mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
49d40e60b8
`guix lint` reports two CVEs, both are unrelated: - CVE-2018-5200: for vendor "pandora" and some 4.2.2.x version - CVE-2019-9133: windows only (I assume it it alsow relates to the "pandora" vendor, since the version the CVE refers to as "solving the issue" does not exist at KDE.) * gnu/packages/kde-multimedia.scm (kmplayer): New variable. * gnu/packages/patches/kmplayer-aarch64.patch, gnu/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch: New files. * gnu/local.mk: Add them.
57 lines
1.5 KiB
Diff
57 lines
1.5 KiB
Diff
Index: b/src/moz-sdk/prcpucfg.h
|
|
===================================================================
|
|
--- a/src/moz-sdk/prcpucfg.h
|
|
+++ b/src/moz-sdk/prcpucfg.h
|
|
@@ -288,6 +288,52 @@
|
|
#define PR_BYTES_PER_WORD_LOG2 3
|
|
#define PR_BYTES_PER_DWORD_LOG2 3
|
|
|
|
+#elif defined(__aarch64__)
|
|
+
|
|
+#define IS_LITTLE_ENDIAN 1
|
|
+#undef IS_BIG_ENDIAN
|
|
+#define IS_64
|
|
+
|
|
+#define PR_BYTES_PER_BYTE 1
|
|
+#define PR_BYTES_PER_SHORT 2
|
|
+#define PR_BYTES_PER_INT 4
|
|
+#define PR_BYTES_PER_INT64 8
|
|
+#define PR_BYTES_PER_LONG 8
|
|
+#define PR_BYTES_PER_FLOAT 4
|
|
+#define PR_BYTES_PER_DOUBLE 8
|
|
+#define PR_BYTES_PER_WORD 8
|
|
+#define PR_BYTES_PER_DWORD 8
|
|
+
|
|
+#define PR_BITS_PER_BYTE 8
|
|
+#define PR_BITS_PER_SHORT 16
|
|
+#define PR_BITS_PER_INT 32
|
|
+#define PR_BITS_PER_INT64 64
|
|
+#define PR_BITS_PER_LONG 64
|
|
+#define PR_BITS_PER_FLOAT 32
|
|
+#define PR_BITS_PER_DOUBLE 64
|
|
+#define PR_BITS_PER_WORD 64
|
|
+
|
|
+#define PR_BITS_PER_BYTE_LOG2 3
|
|
+#define PR_BITS_PER_SHORT_LOG2 4
|
|
+#define PR_BITS_PER_INT_LOG2 5
|
|
+#define PR_BITS_PER_INT64_LOG2 6
|
|
+#define PR_BITS_PER_LONG_LOG2 6
|
|
+#define PR_BITS_PER_FLOAT_LOG2 5
|
|
+#define PR_BITS_PER_DOUBLE_LOG2 6
|
|
+#define PR_BITS_PER_WORD_LOG2 6
|
|
+
|
|
+#define PR_ALIGN_OF_SHORT 2
|
|
+#define PR_ALIGN_OF_INT 4
|
|
+#define PR_ALIGN_OF_LONG 8
|
|
+#define PR_ALIGN_OF_INT64 8
|
|
+#define PR_ALIGN_OF_FLOAT 4
|
|
+#define PR_ALIGN_OF_DOUBLE 8
|
|
+#define PR_ALIGN_OF_POINTER 8
|
|
+#define PR_ALIGN_OF_WORD 8
|
|
+
|
|
+#define PR_BYTES_PER_WORD_LOG2 3
|
|
+#define PR_BYTES_PER_DWORD_LOG2 3
|
|
+
|
|
#elif defined(__mc68000__)
|
|
|
|
#undef IS_LITTLE_ENDIAN
|