mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 14:28:15 -05:00
13b5b5d10f
ld warns about exec stack now, making some tests fail. Fix them (and also remove an unwarranted exec stack from libHSrts along with it). * gnu/packages/patches/ghc-9-StgCRunAsm-only-when-needed.patch * gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch: New patches. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10, ghc-9.0, ghc-9.2, ghc-9.4): Use them. Change-Id: I8e5fc71d7394527d44ff37b1f9bd59d4971ec010
10 lines
517 B
Diff
10 lines
517 B
Diff
--- a/testsuite/tests/driver/recomp015/Makefile 2024-01-13 16:22:42.643106725 +0100
|
|
+++ b/testsuite/tests/driver/recomp015/Makefile 2024-01-13 16:23:18.406867917 +0100
|
|
@@ -26,6 +26,7 @@
|
|
# number of sections)
|
|
'$(TEST_HC)' $(TEST_HC_OPTS) Generate.hs
|
|
./Generate > ManySections.s
|
|
+ echo '.section .note.GNU-stack,"",@progbits' > ManySections.s
|
|
echo 'main = putStrLn "Running main..."' > Main.hs
|
|
'$(TEST_HC)' $(TEST_HC_OPTS) -c ManySections.s
|
|
'$(TEST_HC)' $(TEST_HC_OPTS) --make -O Main.hs ManySections.o
|