mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 23:32:24 -05:00
bab9a8ba0f
* gnu/packages/fontutils.scm (graphite2)[replacement]: New field. (graphite2/fixed): New variable. * gnu/packages/patches/graphite2-CVE-2017-5436.patch, gnu/packages/patches/graphite2-check-code-point-limit.patch, gnu/packages/patches/graphite2-fix-32-bit-wrap-arounds.patch, gnu/packages/patches/graphite2-non-linear-classes-even-number.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
25 lines
811 B
Diff
25 lines
811 B
Diff
From 1ce331d5548b98ed8b818532b2556d6f2c7a3b83 Mon Sep 17 00:00:00 2001
|
|
From: Martin Hosken <martin_hosken@sil.org>
|
|
Date: Thu, 9 Mar 2017 22:04:04 +0000
|
|
Subject: [PATCH] Ensure features have enough space. Fix from Mozilla
|
|
|
|
---
|
|
src/FeatureMap.cpp | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/FeatureMap.cpp b/src/FeatureMap.cpp
|
|
index b8c8405..83bd5f6 100644
|
|
--- a/src/FeatureMap.cpp
|
|
+++ b/src/FeatureMap.cpp
|
|
@@ -275,7 +275,7 @@ bool FeatureRef::applyValToFeature(uint32 val, Features & pDest) const
|
|
else
|
|
if (pDest.m_pMap!=&m_pFace->theSill().theFeatureMap())
|
|
return false; //incompatible
|
|
- pDest.reserve(m_index);
|
|
+ pDest.reserve(m_index+1);
|
|
pDest[m_index] &= ~m_mask;
|
|
pDest[m_index] |= (uint32(val) << m_bits);
|
|
return true;
|
|
--
|
|
2.12.2
|
|
|