mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
aac3a33d1e
Apply a patch backported from Ragel's "ragel-6" branch that allows it to reliably generate usable code on aarch64-linux where the C/C++ "char" type is unsigned by default, fixing the build of Knot on this platform. * gnu/packages/patches/ragel-char-signedness.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ragel.scm (ragel)[arguments]: Add custom phase for AArch64 that applies the patch. [native-inputs]: Add "patch" and patch file on AArch64. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
42 lines
2.6 KiB
Diff
42 lines
2.6 KiB
Diff
From 2e638fccd81e96ce09841adc4b295b5ce694ea73 Mon Sep 17 00:00:00 2001
|
|
From: Adrian Thurston <thurston@colm.net>
|
|
Date: Sat, 6 Nov 2021 12:20:05 -0700
|
|
Subject: [PATCH] C char type: decide signedness of char based on CHAR_MIN
|
|
|
|
Previously had char fixed to signed char, this is not useful on ARM as it does
|
|
not align with the host type. Instead, decide at runtime (or probably compile
|
|
time) if char is signed or not.
|
|
---
|
|
ragel/common.cpp | 16 ++++++++--------
|
|
1 file changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/ragel/common.cpp b/ragel/common.cpp
|
|
index 8e9f8ed0..55875c06 100644
|
|
--- a/ragel/common.cpp
|
|
+++ b/ragel/common.cpp
|
|
@@ -27,14 +27,14 @@
|
|
|
|
HostType hostTypesC[] =
|
|
{
|
|
- { "char", 0, "char", true, true, false, CHAR_MIN, CHAR_MAX, 0, 0, sizeof(char) },
|
|
- { "unsigned", "char", "uchar", false, true, false, 0, 0, 0, UCHAR_MAX, sizeof(unsigned char) },
|
|
- { "short", 0, "short", true, true, false, SHRT_MIN, SHRT_MAX, 0, 0, sizeof(short) },
|
|
- { "unsigned", "short", "ushort", false, true, false, 0, 0, 0, USHRT_MAX, sizeof(unsigned short) },
|
|
- { "int", 0, "int", true, true, false, INT_MIN, INT_MAX, 0, 0, sizeof(int) },
|
|
- { "unsigned", "int", "uint", false, true, false, 0, 0, 0, UINT_MAX, sizeof(unsigned int) },
|
|
- { "long", 0, "long", true, true, false, LONG_MIN, LONG_MAX, 0, 0, sizeof(long) },
|
|
- { "unsigned", "long", "ulong", false, true, false, 0, 0, 0, ULONG_MAX, sizeof(unsigned long) }
|
|
+ { "char", 0, "char", (CHAR_MIN != 0), true, false, SCHAR_MIN, SCHAR_MAX, 0, UCHAR_MAX, sizeof(char) },
|
|
+ { "unsigned", "char", "uchar", false, true, false, 0, 0, 0, UCHAR_MAX, sizeof(unsigned char) },
|
|
+ { "short", 0, "short", true, true, false, SHRT_MIN, SHRT_MAX, 0, 0, sizeof(short) },
|
|
+ { "unsigned", "short", "ushort", false, true, false, 0, 0, 0, USHRT_MAX, sizeof(unsigned short) },
|
|
+ { "int", 0, "int", true, true, false, INT_MIN, INT_MAX, 0, 0, sizeof(int) },
|
|
+ { "unsigned", "int", "uint", false, true, false, 0, 0, 0, UINT_MAX, sizeof(unsigned int) },
|
|
+ { "long", 0, "long", true, true, false, LONG_MIN, LONG_MAX, 0, 0, sizeof(long) },
|
|
+ { "unsigned", "long", "ulong", false, true, false, 0, 0, 0, ULONG_MAX, sizeof(unsigned long) }
|
|
};
|
|
|
|
#define S8BIT_MIN -128
|
|
--
|
|
2.33.1
|
|
|