mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
cf0d6d8367
* gnu/packages/build-tools.scm (meson): Update to 0.46.0. * gnu/packages/patches/meson-for-build-rpath.patch: Adapt.
23 lines
952 B
Diff
23 lines
952 B
Diff
This patch removes a part of meson that clears the rpath upon installation.
|
|
This will only be applied to a special version of meson, used for the
|
|
meson-build-system.
|
|
|
|
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
|
|
|
|
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
|
|
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
|
|
@@ -391,14 +391,6 @@
|
|
print("Symlink creation does not work on this platform. "
|
|
"Skipping all symlinking.")
|
|
printed_symlink_error = True
|
|
- if os.path.isfile(outname):
|
|
- try:
|
|
- depfixer.fix_rpath(outname, install_rpath, False)
|
|
- except SystemExit as e:
|
|
- if isinstance(e.code, int) and e.code == 0:
|
|
- pass
|
|
- else:
|
|
- raise
|
|
|
|
def run(args):
|
|
global install_log_file
|