mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 03:45:24 -05:00
825cc7e0d4
* gnu/packages/patches/gnome-shell-CVE-2020-17489.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (gnome-shell)[source]: Add patch.
46 lines
1.6 KiB
Diff
46 lines
1.6 KiB
Diff
From 05b7aec747282f62212b605249d518280ff80059 Mon Sep 17 00:00:00 2001
|
|
From: Ray Strode <rstrode@redhat.com>
|
|
Date: Mon, 27 Jul 2020 10:58:22 -0400
|
|
Subject: [PATCH] loginDialog: Reset auth prompt on vt switch before fade in
|
|
|
|
At the moment, if a user switches to the login screen vt,
|
|
the login screen fades in whatever was on screen prior, and
|
|
then does a reset.
|
|
|
|
It makes more sense to reset first, so we fade in what the
|
|
user is going to interact with instead of what they interacted
|
|
with before.
|
|
|
|
Fixes: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/2997
|
|
---
|
|
js/gdm/loginDialog.js | 9 ++++-----
|
|
1 file changed, 4 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/js/gdm/loginDialog.js b/js/gdm/loginDialog.js
|
|
index c3f90dc58..6b35ebb16 100644
|
|
--- a/js/gdm/loginDialog.js
|
|
+++ b/js/gdm/loginDialog.js
|
|
@@ -920,16 +920,15 @@ var LoginDialog = GObject.registerClass({
|
|
if (this.opacity == 255 && this._authPrompt.verificationStatus == AuthPrompt.AuthPromptStatus.NOT_VERIFYING)
|
|
return;
|
|
|
|
+ if (this._authPrompt.verificationStatus !== AuthPrompt.AuthPromptStatus.NOT_VERIFYING)
|
|
+ this._authPrompt.reset();
|
|
+
|
|
this._bindOpacity();
|
|
this.ease({
|
|
opacity: 255,
|
|
duration: _FADE_ANIMATION_TIME,
|
|
mode: Clutter.AnimationMode.EASE_OUT_QUAD,
|
|
- onComplete: () => {
|
|
- if (this._authPrompt.verificationStatus != AuthPrompt.AuthPromptStatus.NOT_VERIFYING)
|
|
- this._authPrompt.reset();
|
|
- this._unbindOpacity();
|
|
- }
|
|
+ onComplete: () => this._unbindOpacity(),
|
|
});
|
|
}
|
|
|
|
--
|
|
2.30.1
|
|
|