mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
dab2542f84
* gnu/packages/pdf.scm (mupdf): Update to 1.12.0. [source]: Remove obsolete patches. [inputs]: Add freeglut. * gnu/packages/patches/mupdf-CVE-2017-14685.patch, gnu/packages/patches/mupdf-CVE-2017-14686.patch, gnu/packages/patches/mupdf-CVE-2017-14687.patch, gnu/packages/patches/mupdf-CVE-2017-15587.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/mupdf-build-with-openjpeg-2.1.patch: Update and rename to... * gnu/packages/patches/mupdf-build-with-latest-openjpeg.patch: ... new file.
27 lines
796 B
Diff
27 lines
796 B
Diff
Make it possible to build MuPDF with OpenJPEG 2.3, which is the latest
|
|
release series and contains many important bug fixes.
|
|
|
|
Patch adapted from Debian:
|
|
|
|
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745246
|
|
|
|
And related to this upstream commit:
|
|
|
|
http://git.ghostscript.com/?p=mupdf.git;a=commit;h=f88bfe2e62dbadb96d4f52d7aa025f0a516078da
|
|
|
|
diff --git a/source/fitz/load-jpx.c b/source/fitz/load-jpx.c
|
|
index 65699ba..ea84778 100644
|
|
--- a/source/fitz/load-jpx.c
|
|
+++ b/source/fitz/load-jpx.c
|
|
@@ -445,11 +445,6 @@ fz_load_jpx_info(fz_context *ctx, const unsigned char *data, size_t size, int *w
|
|
|
|
#else /* HAVE_LURATECH */
|
|
|
|
-#define OPJ_STATIC
|
|
-#define OPJ_HAVE_INTTYPES_H
|
|
-#if !defined(_MSC_VER) || _MSC_VER >= 1600
|
|
-#define OPJ_HAVE_STDINT_H
|
|
-#endif
|
|
#define USE_JPIP
|
|
|
|
#include <openjpeg.h>
|