mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-19 21:27:37 -05:00
ceb9de75a6
* gnu/packages/patches/python-2.7-search-paths.patch: Add cross-compilation support. * gnu/packages/patches/python-3-search-paths.patch: Ditto. * gnu/packages/patches/python-cross-compile.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add above new patch. * gnu/packages/python.scm (python-2.7)[patches]: Add new patch above, [arguments]: Set _PYTHON_HOST_PLATFORM env variable when cross compiling.
20 lines
983 B
Diff
20 lines
983 B
Diff
Make sure the build system honors CPATH and LIBRARY_PATH when
|
|
looking for headers and libraries.
|
|
|
|
--- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200
|
|
+++ Python-2.7.10/setup.py 2015-10-07 18:33:47.497347552 +0200
|
|
@@ -526,6 +526,14 @@ class PyBuildExt(build_ext):
|
|
inc_dirs += ['/system/include', '/atheos/autolnk/include']
|
|
inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
|
|
|
|
+ # Always honor these variables.
|
|
+ if not cross_compiling:
|
|
+ lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
|
|
+ inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
|
|
+ else:
|
|
+ lib_dirs = os.getenv('CROSS_LIBRARY_PATH', '').split(os.pathsep)
|
|
+ inc_dirs = os.getenv('CROSS_CPATH', '').split(os.pathsep)
|
|
+
|
|
# OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
|
|
if host_platform in ['osf1', 'unixware7', 'openunix8']:
|
|
lib_dirs += ['/usr/ccs/lib']
|