mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 03:15:09 -05:00
be9b7e0f65
* gnu/packages/patches/xpra-4.2-install_libs.patch: Move to ... * gnu/packages/patches/xpra-5.0-install_libs.patch: ... this file. * gnu/packages/patches/xpra-4.2-systemd-run.patch: Move to ... * gnu/packages/patches/xpra-5.0-systemd-run.patch: ... this file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/xorg.scm (xpra): Update to 5.0.2. [source] <patches>: Rename per version changes [inputs]: Add cups. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
42 lines
1.8 KiB
Diff
42 lines
1.8 KiB
Diff
Distribution specific patch, not going upstream
|
|
|
|
This workaround for Gentoo interferes with our use of --no-compile during
|
|
the 'install stage.
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index e254bf99c..90db55c3f 100755
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -663,8 +663,6 @@ if modules_ENABLED:
|
|
# Utility methods for building with Cython
|
|
|
|
def add_cython_ext(*args, **kwargs):
|
|
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
|
|
- return
|
|
if not cython_ENABLED:
|
|
raise ValueError(f"cannot build {args}: cython compilation is disabled")
|
|
if cython_tracing_ENABLED:
|
|
@@ -1809,9 +1807,6 @@ else:
|
|
if root_prefix.endswith("/usr"):
|
|
#ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
|
|
root_prefix = root_prefix[:-4]
|
|
- for x in sys.argv:
|
|
- if x.startswith("--root="):
|
|
- root_prefix = x[len("--root="):]
|
|
print(f"install_data_override.run() root_prefix={root_prefix}")
|
|
build_xpra_conf(root_prefix)
|
|
|
|
@@ -1955,13 +1950,6 @@ else:
|
|
if uinput_ENABLED:
|
|
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
|
|
|
|
- #gentoo does weird things, calls --no-compile with build *and* install
|
|
- #then expects to find the cython modules!? ie:
|
|
- #> python2.7 setup.py build -b build-2.7 install --no-compile \
|
|
- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
|
|
- #otherwise we use the flags to skip pkgconfig
|
|
- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
|
|
- pkgconfig = no_pkgconfig
|
|
|
|
if OSX and "py2app" in sys.argv:
|
|
import py2app #@UnresolvedImport
|