mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
77e99a79eb
* gnu/packages/audio.scm (webrtc-audio-processing)[arguments]: New field. * gnu/packages/patches/webrtc-audio-processing-byte-order-pointer-size.patch, gnu/packages/patches/webrtc-audio-processing-x86-no-sse.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Change-Id: I3a95e5e2794df0d51e005672b5d3e2d98f27b767 Co-authored-by: Ludovic Courtès <ludo@gnu.org>
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
https://bugs.gentoo.org/917493
|
|
https://sources.debian.org/src/webrtc-audio-processing/1.0-0.2/debian/patches/Add-generic-byte-order-and-pointer-size-detection.patch/
|
|
|
|
Description: Add generic byte order and pointer size detection
|
|
Author: Than <than@redhat.com>
|
|
Origin: https://bugs.freedesktop.org/show_bug.cgi?id=95738#c4
|
|
Last-Update: 2022-02-01
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
--- a/webrtc/rtc_base/system/arch.h
|
|
+++ b/webrtc/rtc_base/system/arch.h
|
|
@@ -58,7 +58,19 @@
|
|
#define WEBRTC_ARCH_32_BITS
|
|
#define WEBRTC_ARCH_LITTLE_ENDIAN
|
|
#else
|
|
-#error Please add support for your architecture in rtc_base/system/arch.h
|
|
+/* instead of failing, use typical unix defines... */
|
|
+#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
|
|
+#define WEBRTC_ARCH_LITTLE_ENDIAN
|
|
+#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
|
+#define WEBRTC_ARCH_BIG_ENDIAN
|
|
+#else
|
|
+#error __BYTE_ORDER__ is not defined
|
|
+#endif
|
|
+#if defined(__LP64__)
|
|
+#define WEBRTC_ARCH_64_BITS
|
|
+#else
|
|
+#define WEBRTC_ARCH_32_BITS
|
|
+#endif
|
|
#endif
|
|
|
|
#if !(defined(WEBRTC_ARCH_LITTLE_ENDIAN) ^ defined(WEBRTC_ARCH_BIG_ENDIAN))
|