mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
a33eac038a
* gnu/packages/patches/glibc-supported-locales.patch: Adjust for upstream changes. * gnu/packages/patches/glibc-2.29-supported-locales.patch: New file, with previous contents. * gnu/packages/patches/gcc-4.9-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-6-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-7-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-8-libsanitizer-mode-size.patch, gnu/packages/patches/gcc-9-libsanitizer-mode-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gcc.scm (gcc-4.9, gcc-5, gcc-6, gcc-7, gcc-8, gcc-9)[source](patches): Add the respective patch files. * gnu/packages/base.scm (glibc): Update to 2.31. [source](patches): Remove obsolete. (glibc-2.30): New public variable. (glibc-2.29)[source](patches): Adjust for renamed patch file.
32 lines
1,008 B
Diff
32 lines
1,008 B
Diff
This patch is taken from debian's glibc package (generate-supported.mk).
|
|
It install the localedata/SUPPORTED file of the glibc. This file lists
|
|
all the supported locales of the glibc.
|
|
|
|
diff --git a/localedata/Makefile b/localedata/Makefile
|
|
--- a/localedata/Makefile
|
|
+++ b/localedata/Makefile
|
|
@@ -176,7 +176,8 @@
|
|
else
|
|
install-others := $(addprefix $(inst_i18ndir)/, \
|
|
$(addsuffix .gz, $(charmaps)) \
|
|
- $(locales))
|
|
+ $(locales)) \
|
|
+ $(inst_i18ndir)/SUPPORTED
|
|
endif
|
|
|
|
tests: $(objdir)/iconvdata/gconv-modules
|
|
@@ -401,6 +402,14 @@
|
|
|
|
include SUPPORTED
|
|
|
|
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
|
|
+ for locale in $(SUPPORTED-LOCALES); do \
|
|
+ [ $$locale = true ] && continue; \
|
|
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
|
|
+ done
|
|
+ $(make-target-directory)
|
|
+ $(INSTALL_DATA) LOCALES $@
|
|
+
|
|
INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES))
|
|
INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES))
|
|
|