mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-02 09:28:57 -05:00
bbeb710de7
* gnu/packages/crypto.scm (hash-extender): New variable. * gnu/packages/patches/hash-extender-test-suite.patch: New file. * gnu/local.mk (dist_patch_DATA): Register the new file.
13 lines
500 B
Diff
13 lines
500 B
Diff
Make the test suite exit with a non-zero exit code if some tests failed.
|
|
Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
|
|
--- a/test.c
|
|
+++ b/test.c
|
|
@@ -79,5 +79,9 @@ void test_report(void)
|
|
printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
|
|
printf("--------------------------------------------------------------------------------\n");
|
|
}
|
|
+
|
|
+ if (tests_passed != tests_run) {
|
|
+ exit(1);
|
|
+ }
|
|
}
|