mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 03:45:24 -05:00
fc2ff004f7
* gnu/packages/emulators.scm (ppsspp): Update to 1.12.3. [inputs]: Convert to new style. Add bash. Remove armips-source, lang and tests. [arguments]: Convert to list of g-exps. <#:phases>: Drop trailing #t. Directly refer to armips source and pspautotests. Check for #:tests? flag. Reenable VFPUSinCos test. * gnu/packages/patches/ppsspp-disable-upgrade-and-gold.patch: Adjust to version 1.12.3.
543 lines
23 KiB
Diff
543 lines
23 KiB
Diff
From debc32a287209e1d1bb6fedb479bd923fd016399 Mon Sep 17 00:00:00 2001
|
|
From: Liliana Marie Prikler <liliana.prikler@gmail.com>
|
|
Date: Sat, 5 Jun 2021 22:47:00 -0400
|
|
Subject: [PATCH] ppsspp: Remove upgrade code and gold support.
|
|
|
|
Original patch from Liliana Marie Prikler.
|
|
Rebased on master (commit 69fa20744958aef8da9ca052ba7675fdc1636e46) by
|
|
Maxim Cournoyer.
|
|
Revised once again by Liliana Marie Prikler for version 1.12.3.
|
|
---
|
|
Common/System/System.h | 1 -
|
|
Core/Config.cpp | 12 -------
|
|
Core/Config.h | 2 --
|
|
Qt/QtMain.cpp | 6 ----
|
|
Qt/mainwindow.cpp | 6 ----
|
|
Qt/mainwindow.h | 1 -
|
|
SDL/SDLMain.cpp | 6 ----
|
|
UI/DevScreens.cpp | 3 --
|
|
UI/GameSettingsScreen.cpp | 4 +--
|
|
UI/MainScreen.cpp | 70 +------------------------------------
|
|
UI/MemStickScreen.cpp | 8 -----
|
|
UI/MiscScreens.cpp | 31 ++--------------
|
|
UWP/PPSSPP_UWPMain.cpp | 6 ----
|
|
Windows/MainWindowMenu.cpp | 8 +----
|
|
Windows/WindowsHost.cpp | 4 ---
|
|
Windows/main.cpp | 6 ----
|
|
Windows/resource.h | 1 -
|
|
android/jni/app-android.cpp | 6 ----
|
|
ios/main.mm | 6 ----
|
|
19 files changed, 6 insertions(+), 181 deletions(-)
|
|
|
|
diff --git a/Common/System/System.h b/Common/System/System.h
|
|
index 09560191e..5df68a120 100644
|
|
--- a/Common/System/System.h
|
|
+++ b/Common/System/System.h
|
|
@@ -83,7 +83,6 @@ enum SystemProperty {
|
|
SYSPROP_DISPLAY_SAFE_INSET_BOTTOM,
|
|
|
|
SYSPROP_DEVICE_TYPE,
|
|
- SYSPROP_APP_GOLD, // To avoid having #ifdef GOLD other than in main.cpp and similar.
|
|
|
|
// Exposed on Android. Choosing the optimal sample rate for audio
|
|
// will result in lower latencies. Buffer size is automatically matched
|
|
diff --git a/Core/Config.cpp b/Core/Config.cpp
|
|
index 305098f47..9c28a3315 100644
|
|
--- a/Core/Config.cpp
|
|
+++ b/Core/Config.cpp
|
|
@@ -512,7 +512,6 @@ static ConfigSetting generalSettings[] = {
|
|
ConfigSetting("IgnoreBadMemAccess", &g_Config.bIgnoreBadMemAccess, true, true),
|
|
ConfigSetting("CurrentDirectory", &g_Config.currentDirectory, ""),
|
|
ConfigSetting("ShowDebuggerOnLoad", &g_Config.bShowDebuggerOnLoad, false),
|
|
- ConfigSetting("CheckForNewVersion", &g_Config.bCheckForNewVersion, true),
|
|
ConfigSetting("Language", &g_Config.sLanguageIni, &DefaultLangRegion),
|
|
ConfigSetting("ForceLagSync2", &g_Config.bForceLagSync, false, true, true),
|
|
ConfigSetting("DiscordPresence", &g_Config.bDiscordPresence, true, true, false), // Or maybe it makes sense to have it per-game? Race conditions abound...
|
|
@@ -1395,17 +1394,6 @@ void Config::Load(const char *iniFileName, const char *controllerIniFilename) {
|
|
upgradeMessage = "";
|
|
}
|
|
|
|
- // Check for new version on every 10 runs.
|
|
- // Sometimes the download may not be finished when the main screen shows (if the user dismisses the
|
|
- // splash screen quickly), but then we'll just show the notification next time instead, we store the
|
|
- // upgrade number in the ini.
|
|
- if (iRunCount % 10 == 0 && bCheckForNewVersion) {
|
|
- const char *versionUrl = "http://www.ppsspp.org/version.json";
|
|
- const char *acceptMime = "application/json, text/*; q=0.9, */*; q=0.8";
|
|
- auto dl = g_DownloadManager.StartDownloadWithCallback(versionUrl, Path(), &DownloadCompletedCallback, acceptMime);
|
|
- dl->SetHidden(true);
|
|
- }
|
|
-
|
|
INFO_LOG(LOADER, "Loading controller config: %s", controllerIniFilename_.c_str());
|
|
bSaveSettings = true;
|
|
|
|
diff --git a/Core/Config.h b/Core/Config.h
|
|
index 7bbbf2798..1bc1c2296 100644
|
|
--- a/Core/Config.h
|
|
+++ b/Core/Config.h
|
|
@@ -109,7 +109,6 @@ struct Config {
|
|
|
|
bool bFastMemory;
|
|
int iCpuCore;
|
|
- bool bCheckForNewVersion;
|
|
bool bForceLagSync;
|
|
bool bFuncReplacements;
|
|
bool bHideSlowWarnings;
|
|
@@ -562,4 +561,3 @@ std::string CreateRandMAC();
|
|
// TODO: Find a better place for this.
|
|
extern http::Downloader g_DownloadManager;
|
|
extern Config g_Config;
|
|
-
|
|
diff --git a/Qt/QtMain.cpp b/Qt/QtMain.cpp
|
|
index b642f7442..a880d7c94 100644
|
|
--- a/Qt/QtMain.cpp
|
|
+++ b/Qt/QtMain.cpp
|
|
@@ -219,12 +219,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
|
|
case SYSPROP_HAS_FILE_BROWSER:
|
|
case SYSPROP_HAS_FOLDER_BROWSER:
|
|
return true;
|
|
- case SYSPROP_APP_GOLD:
|
|
-#ifdef GOLD
|
|
- return true;
|
|
-#else
|
|
- return false;
|
|
-#endif
|
|
case SYSPROP_CAN_JIT:
|
|
return true;
|
|
default:
|
|
diff --git a/Qt/mainwindow.cpp b/Qt/mainwindow.cpp
|
|
index 1f56e0e76..0b7680427 100644
|
|
--- a/Qt/mainwindow.cpp
|
|
+++ b/Qt/mainwindow.cpp
|
|
@@ -413,11 +413,6 @@ void MainWindow::forumAct()
|
|
QDesktopServices::openUrl(QUrl("https://forums.ppsspp.org/"));
|
|
}
|
|
|
|
-void MainWindow::goldAct()
|
|
-{
|
|
- QDesktopServices::openUrl(QUrl("https://central.ppsspp.org/buygold"));
|
|
-}
|
|
-
|
|
void MainWindow::gitAct()
|
|
{
|
|
QDesktopServices::openUrl(QUrl("https://github.com/hrydgard/ppsspp/"));
|
|
@@ -666,7 +661,6 @@ void MainWindow::createMenus()
|
|
MenuTree* helpMenu = new MenuTree(this, menuBar(), QT_TR_NOOP("&Help"));
|
|
helpMenu->add(new MenuAction(this, SLOT(websiteAct()), QT_TR_NOOP("Visit www.&ppsspp.org")));
|
|
helpMenu->add(new MenuAction(this, SLOT(forumAct()), QT_TR_NOOP("PPSSPP &forums")));
|
|
- helpMenu->add(new MenuAction(this, SLOT(goldAct()), QT_TR_NOOP("Buy &Gold")));
|
|
helpMenu->add(new MenuAction(this, SLOT(gitAct()), QT_TR_NOOP("Git&Hub")));
|
|
helpMenu->add(new MenuAction(this, SLOT(discordAct()), QT_TR_NOOP("Discord")));
|
|
helpMenu->addSeparator();
|
|
diff --git a/Qt/mainwindow.h b/Qt/mainwindow.h
|
|
index 99c9fc3ad..8cd6cbf79 100644
|
|
--- a/Qt/mainwindow.h
|
|
+++ b/Qt/mainwindow.h
|
|
@@ -197,7 +197,6 @@ private slots:
|
|
// Help
|
|
void websiteAct();
|
|
void forumAct();
|
|
- void goldAct();
|
|
void gitAct();
|
|
void discordAct();
|
|
void aboutAct();
|
|
diff --git a/SDL/SDLMain.cpp b/SDL/SDLMain.cpp
|
|
index f0f74f979..f963f36e9 100644
|
|
--- a/SDL/SDLMain.cpp
|
|
+++ b/SDL/SDLMain.cpp
|
|
@@ -381,12 +381,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
|
|
switch (prop) {
|
|
case SYSPROP_HAS_BACK_BUTTON:
|
|
return true;
|
|
- case SYSPROP_APP_GOLD:
|
|
-#ifdef GOLD
|
|
- return true;
|
|
-#else
|
|
- return false;
|
|
-#endif
|
|
case SYSPROP_CAN_JIT:
|
|
return true;
|
|
default:
|
|
diff --git a/UI/DevScreens.cpp b/UI/DevScreens.cpp
|
|
index 389fdf096..8442ee8c6 100644
|
|
--- a/UI/DevScreens.cpp
|
|
+++ b/UI/DevScreens.cpp
|
|
@@ -649,9 +649,6 @@ void SystemInfoScreen::CreateViews() {
|
|
#ifdef _M_SSE
|
|
buildConfig->Add(new InfoItem("_M_SSE", StringFromFormat("0x%x", _M_SSE)));
|
|
#endif
|
|
- if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- buildConfig->Add(new InfoItem("GOLD", ""));
|
|
- }
|
|
|
|
ViewGroup *cpuExtensionsScroll = new ScrollView(ORIENT_VERTICAL, new LinearLayoutParams(FILL_PARENT, FILL_PARENT));
|
|
cpuExtensionsScroll->SetTag("DevSystemInfoCPUExt");
|
|
diff --git a/UI/GameSettingsScreen.cpp b/UI/GameSettingsScreen.cpp
|
|
index 99fb151b9..90f26d5dc 100644
|
|
--- a/UI/GameSettingsScreen.cpp
|
|
+++ b/UI/GameSettingsScreen.cpp
|
|
@@ -1023,7 +1023,6 @@ void GameSettingsScreen::CreateViews() {
|
|
}
|
|
}
|
|
#endif
|
|
- systemSettings->Add(new CheckBox(&g_Config.bCheckForNewVersion, sy->T("VersionCheck", "Check for new versions of PPSSPP")));
|
|
|
|
systemSettings->Add(new Choice(sy->T("Restore Default Settings")))->OnClick.Handle(this, &GameSettingsScreen::OnRestoreDefaultSettings);
|
|
systemSettings->Add(new CheckBox(&g_Config.bEnableStateUndo, sy->T("Savestate slot backups")));
|
|
@@ -2076,8 +2075,7 @@ void GestureMappingScreen::CreateViews() {
|
|
vert->Add(new PopupMultiChoice(&g_Config.iSwipeRight, mc->T("Swipe Right"), gestureButton, 0, ARRAY_SIZE(gestureButton), mc->GetName(), screenManager()))->SetEnabledPtr(&g_Config.bGestureControlEnabled);
|
|
vert->Add(new PopupSliderChoiceFloat(&g_Config.fSwipeSensitivity, 0.01f, 1.0f, co->T("Swipe sensitivity"), 0.01f, screenManager(), "x"))->SetEnabledPtr(&g_Config.bGestureControlEnabled);
|
|
vert->Add(new PopupSliderChoiceFloat(&g_Config.fSwipeSmoothing, 0.0f, 0.95f, co->T("Swipe smoothing"), 0.05f, screenManager(), "x"))->SetEnabledPtr(&g_Config.bGestureControlEnabled);
|
|
-
|
|
+
|
|
vert->Add(new ItemHeader(co->T("Double tap")));
|
|
vert->Add(new PopupMultiChoice(&g_Config.iDoubleTapGesture, mc->T("Double tap button"), gestureButton, 0, ARRAY_SIZE(gestureButton), mc->GetName(), screenManager()))->SetEnabledPtr(&g_Config.bGestureControlEnabled);
|
|
}
|
|
-
|
|
diff --git a/UI/MainScreen.cpp b/UI/MainScreen.cpp
|
|
index 4e86ac1ab..be49c3add 100644
|
|
--- a/UI/MainScreen.cpp
|
|
+++ b/UI/MainScreen.cpp
|
|
@@ -1100,11 +1100,7 @@ void MainScreen::CreateViews() {
|
|
sprintf(versionString, "%s", PPSSPP_GIT_VERSION);
|
|
rightColumnItems->SetSpacing(0.0f);
|
|
AnchorLayout *logos = new AnchorLayout(new AnchorLayoutParams(FILL_PARENT, 60.0f, false));
|
|
- if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- logos->Add(new ImageView(ImageID("I_ICONGOLD"), "", IS_DEFAULT, new AnchorLayoutParams(64, 64, 0, 0, NONE, NONE, false)));
|
|
- } else {
|
|
- logos->Add(new ImageView(ImageID("I_ICON"), "", IS_DEFAULT, new AnchorLayoutParams(64, 64, 0, 0, NONE, NONE, false)));
|
|
- }
|
|
+ logos->Add(new ImageView(ImageID("I_ICON"), "", IS_DEFAULT, new AnchorLayoutParams(64, 64, 0, 0, NONE, NONE, false)));
|
|
logos->Add(new ImageView(ImageID("I_LOGO"), "PPSSPP", IS_DEFAULT, new AnchorLayoutParams(180, 64, 64, -5.0f, NONE, NONE, false)));
|
|
|
|
#if !defined(MOBILE_DEVICE)
|
|
@@ -1127,11 +1123,6 @@ void MainScreen::CreateViews() {
|
|
rightColumnItems->Add(new Choice(mm->T("Game Settings", "Settings")))->OnClick.Handle(this, &MainScreen::OnGameSettings);
|
|
rightColumnItems->Add(new Choice(mm->T("Credits")))->OnClick.Handle(this, &MainScreen::OnCredits);
|
|
rightColumnItems->Add(new Choice(mm->T("www.ppsspp.org")))->OnClick.Handle(this, &MainScreen::OnPPSSPPOrg);
|
|
- if (!System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- Choice *gold = rightColumnItems->Add(new Choice(mm->T("Buy PPSSPP Gold")));
|
|
- gold->OnClick.Handle(this, &MainScreen::OnSupport);
|
|
- gold->SetIcon(ImageID("I_ICONGOLD"), 0.5f);
|
|
- }
|
|
|
|
#if !PPSSPP_PLATFORM(UWP)
|
|
// Having an exit button is against UWP guidelines.
|
|
@@ -1156,32 +1147,6 @@ void MainScreen::CreateViews() {
|
|
} else if (tabHolder_->GetVisibility() != V_GONE) {
|
|
root_->SetDefaultFocusView(tabHolder_);
|
|
}
|
|
-
|
|
- auto u = GetI18NCategory("Upgrade");
|
|
-
|
|
- upgradeBar_ = 0;
|
|
- if (!g_Config.upgradeMessage.empty()) {
|
|
- upgradeBar_ = new LinearLayout(ORIENT_HORIZONTAL, new LinearLayoutParams(FILL_PARENT, WRAP_CONTENT));
|
|
-
|
|
- UI::Margins textMargins(10, 5);
|
|
- UI::Margins buttonMargins(0, 0);
|
|
- UI::Drawable solid(0xFFbd9939);
|
|
- upgradeBar_->SetBG(solid);
|
|
- upgradeBar_->Add(new TextView(u->T("New version of PPSSPP available") + std::string(": ") + g_Config.upgradeVersion, new LinearLayoutParams(1.0f, textMargins)));
|
|
-#if PPSSPP_PLATFORM(ANDROID) || PPSSPP_PLATFORM(WINDOWS)
|
|
- upgradeBar_->Add(new Button(u->T("Download"), new LinearLayoutParams(buttonMargins)))->OnClick.Handle(this, &MainScreen::OnDownloadUpgrade);
|
|
-#else
|
|
- upgradeBar_->Add(new Button(u->T("Details"), new LinearLayoutParams(buttonMargins)))->OnClick.Handle(this, &MainScreen::OnDownloadUpgrade);
|
|
-#endif
|
|
- upgradeBar_->Add(new Button(u->T("Dismiss"), new LinearLayoutParams(buttonMargins)))->OnClick.Handle(this, &MainScreen::OnDismissUpgrade);
|
|
-
|
|
- // Slip in under root_
|
|
- LinearLayout *newRoot = new LinearLayout(ORIENT_VERTICAL);
|
|
- newRoot->Add(root_);
|
|
- newRoot->Add(upgradeBar_);
|
|
- root_->ReplaceLayoutParams(new LinearLayoutParams(1.0));
|
|
- root_ = newRoot;
|
|
- }
|
|
}
|
|
|
|
UI::EventReturn MainScreen::OnAllowStorage(UI::EventParams &e) {
|
|
@@ -1189,30 +1154,6 @@ UI::EventReturn MainScreen::OnAllowStorage(UI::EventParams &e) {
|
|
return UI::EVENT_DONE;
|
|
}
|
|
|
|
-UI::EventReturn MainScreen::OnDownloadUpgrade(UI::EventParams &e) {
|
|
-#if PPSSPP_PLATFORM(ANDROID)
|
|
- // Go to app store
|
|
- if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- LaunchBrowser("market://details?id=org.ppsspp.ppssppgold");
|
|
- } else {
|
|
- LaunchBrowser("market://details?id=org.ppsspp.ppsspp");
|
|
- }
|
|
-#elif PPSSPP_PLATFORM(WINDOWS)
|
|
- LaunchBrowser("https://www.ppsspp.org/downloads.html");
|
|
-#else
|
|
- // Go directly to ppsspp.org and let the user sort it out
|
|
- // (for details and in case downloads doesn't have their platform.)
|
|
- LaunchBrowser("https://www.ppsspp.org/");
|
|
-#endif
|
|
- return UI::EVENT_DONE;
|
|
-}
|
|
-
|
|
-UI::EventReturn MainScreen::OnDismissUpgrade(UI::EventParams &e) {
|
|
- g_Config.DismissUpgrade();
|
|
- upgradeBar_->SetVisibility(UI::V_GONE);
|
|
- return UI::EVENT_DONE;
|
|
-}
|
|
-
|
|
void MainScreen::sendMessage(const char *message, const char *value) {
|
|
// Always call the base class method first to handle the most common messages.
|
|
UIScreenWithBackground::sendMessage(message, value);
|
|
@@ -1386,15 +1327,6 @@ UI::EventReturn MainScreen::OnCredits(UI::EventParams &e) {
|
|
return UI::EVENT_DONE;
|
|
}
|
|
|
|
-UI::EventReturn MainScreen::OnSupport(UI::EventParams &e) {
|
|
-#ifdef __ANDROID__
|
|
- LaunchBrowser("market://details?id=org.ppsspp.ppssppgold");
|
|
-#else
|
|
- LaunchBrowser("https://central.ppsspp.org/buygold");
|
|
-#endif
|
|
- return UI::EVENT_DONE;
|
|
-}
|
|
-
|
|
UI::EventReturn MainScreen::OnPPSSPPOrg(UI::EventParams &e) {
|
|
LaunchBrowser("https://www.ppsspp.org");
|
|
return UI::EVENT_DONE;
|
|
diff --git a/UI/MemStickScreen.cpp b/UI/MemStickScreen.cpp
|
|
index ef617c5b5..664614c62 100644
|
|
--- a/UI/MemStickScreen.cpp
|
|
+++ b/UI/MemStickScreen.cpp
|
|
@@ -157,23 +157,16 @@ static void AddExplanation(UI::ViewGroup *viewGroup, MemStickScreen::Choice choi
|
|
case MemStickScreen::CHOICE_STORAGE_ROOT:
|
|
// Old school choice
|
|
holder->Add(new TextView(iz->T("DataWillStay", "Data will stay even if you uninstall PPSSPP"), flags, false))->SetBullet(true);
|
|
- holder->Add(new TextView(iz->T("DataCanBeShared", "Data can be shared between PPSSPP regular/Gold"), flags, false))->SetBullet(true);
|
|
holder->Add(new TextView(iz->T("EasyUSBAccess", "Easy USB access"), flags, false))->SetBullet(true);
|
|
break;
|
|
case MemStickScreen::CHOICE_BROWSE_FOLDER:
|
|
holder->Add(new TextView(iz->T("DataWillStay", "Data will stay even if you uninstall PPSSPP"), flags, false))->SetBullet(true);
|
|
- holder->Add(new TextView(iz->T("DataCanBeShared", "Data can be shared between PPSSPP regular/Gold"), flags, false))->SetBullet(true);
|
|
holder->Add(new TextView(iz->T("EasyUSBAccess", "Easy USB access"), flags, false))->SetBullet(true);
|
|
break;
|
|
case MemStickScreen::CHOICE_PRIVATE_DIRECTORY:
|
|
// Consider https://www.compart.com/en/unicode/U+26A0 (unicode warning sign?)? or a graphic?
|
|
holder->Add(new TextView(iz->T("DataWillBeLostOnUninstall", "Warning! Data will be lost when you uninstall PPSSPP!"), flags, false))->SetBullet(true);
|
|
- holder->Add(new TextView(iz->T("DataCannotBeShared", "Data CANNOT be shared between PPSSPP regular/Gold!"), flags, false))->SetBullet(true);
|
|
-#if GOLD
|
|
- holder->Add(new TextView(iz->T("USBAccessThroughGold", "USB access through Android/data/org.ppsspp.ppssppgold/files"), flags, false))->SetBullet(true);
|
|
-#else
|
|
holder->Add(new TextView(iz->T("USBAccessThrough", "USB access through Android/data/org.ppsspp.ppsspp/files"), flags, false))->SetBullet(true);
|
|
-#endif
|
|
break;
|
|
case MemStickScreen::CHOICE_SET_MANUAL:
|
|
default:
|
|
@@ -243,7 +236,6 @@ void MemStickScreen::CreateViews() {
|
|
} else {
|
|
leftColumn->Add(new RadioButton(&choice_, CHOICE_SET_MANUAL, iz->T("Manually specify PSP folder")))->OnClick.Handle(this, &MemStickScreen::OnChoiceClick);
|
|
leftColumn->Add(new TextView(iz->T("DataWillStay", "Data will stay even if you uninstall PPSSPP.")))->SetBullet(true);
|
|
- leftColumn->Add(new TextView(iz->T("DataCanBeShared", "Data can be shared between PPSSPP regular/Gold.")))->SetBullet(true);
|
|
// TODO: Show current folder here if we have one set.
|
|
}
|
|
if (choice_ == CHOICE_BROWSE_FOLDER || choice_ == CHOICE_SET_MANUAL) {
|
|
diff --git a/UI/MiscScreens.cpp b/UI/MiscScreens.cpp
|
|
index 04e5df6c3..fb6c29725 100644
|
|
--- a/UI/MiscScreens.cpp
|
|
+++ b/UI/MiscScreens.cpp
|
|
@@ -769,11 +769,7 @@ void LogoScreen::render() {
|
|
char temp[256];
|
|
// Manually formatting UTF-8 is fun. \xXX doesn't work everywhere.
|
|
snprintf(temp, sizeof(temp), "%s Henrik Rydg%c%crd", cr->T("created", "Created by"), 0xC3, 0xA5);
|
|
- if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- dc.Draw()->DrawImage(ImageID("I_ICONGOLD"), bounds.centerX() - 120, bounds.centerY() - 30, 1.2f, textColor, ALIGN_CENTER);
|
|
- } else {
|
|
- dc.Draw()->DrawImage(ImageID("I_ICON"), bounds.centerX() - 120, bounds.centerY() - 30, 1.2f, textColor, ALIGN_CENTER);
|
|
- }
|
|
+ dc.Draw()->DrawImage(ImageID("I_ICON"), bounds.centerX() - 120, bounds.centerY() - 30, 1.2f, textColor, ALIGN_CENTER);
|
|
dc.Draw()->DrawImage(ImageID("I_LOGO"), bounds.centerX() + 40, bounds.centerY() - 30, 1.5f, textColor, ALIGN_CENTER);
|
|
//dc.Draw()->DrawTextShadow(UBUNTU48, "PPSSPP", bounds.w / 2, bounds.h / 2 - 30, textColor, ALIGN_CENTER);
|
|
dc.SetFontScale(1.0f, 1.0f);
|
|
@@ -809,10 +805,6 @@ void CreditsScreen::CreateViews() {
|
|
// Really need to redo this whole layout with some linear layouts...
|
|
|
|
int rightYOffset = 0;
|
|
- if (!System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- root_->Add(new Button(cr->T("Buy Gold"), new AnchorLayoutParams(260, 64, NONE, NONE, 10, 84, false)))->OnClick.Handle(this, &CreditsScreen::OnSupport);
|
|
- rightYOffset = 74;
|
|
- }
|
|
root_->Add(new Button(cr->T("PPSSPP Forums"), new AnchorLayoutParams(260, 64, 10, NONE, NONE, 158, false)))->OnClick.Handle(this, &CreditsScreen::OnForums);
|
|
root_->Add(new Button(cr->T("Discord"), new AnchorLayoutParams(260, 64, 10, NONE, NONE, 232, false)))->OnClick.Handle(this, &CreditsScreen::OnDiscord);
|
|
root_->Add(new Button("www.ppsspp.org", new AnchorLayoutParams(260, 64, 10, NONE, NONE, 10, false)))->OnClick.Handle(this, &CreditsScreen::OnPPSSPPOrg);
|
|
@@ -821,20 +813,7 @@ void CreditsScreen::CreateViews() {
|
|
#if PPSSPP_PLATFORM(ANDROID) || PPSSPP_PLATFORM(IOS)
|
|
root_->Add(new Button(cr->T("Share PPSSPP"), new AnchorLayoutParams(260, 64, NONE, NONE, 10, rightYOffset + 158, false)))->OnClick.Handle(this, &CreditsScreen::OnShare);
|
|
#endif
|
|
- if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- root_->Add(new ImageView(ImageID("I_ICONGOLD"), "", IS_DEFAULT, new AnchorLayoutParams(100, 64, 10, 10, NONE, NONE, false)));
|
|
- } else {
|
|
- root_->Add(new ImageView(ImageID("I_ICON"), "", IS_DEFAULT, new AnchorLayoutParams(100, 64, 10, 10, NONE, NONE, false)));
|
|
- }
|
|
-}
|
|
-
|
|
-UI::EventReturn CreditsScreen::OnSupport(UI::EventParams &e) {
|
|
-#ifdef __ANDROID__
|
|
- LaunchBrowser("market://details?id=org.ppsspp.ppssppgold");
|
|
-#else
|
|
- LaunchBrowser("https://central.ppsspp.org/buygold");
|
|
-#endif
|
|
- return UI::EVENT_DONE;
|
|
+ root_->Add(new ImageView(ImageID("I_ICON"), "", IS_DEFAULT, new AnchorLayoutParams(100, 64, 10, 10, NONE, NONE, false)));
|
|
}
|
|
|
|
UI::EventReturn CreditsScreen::OnTwitter(UI::EventParams &e) {
|
|
@@ -1024,11 +1003,7 @@ void CreditsScreen::render() {
|
|
|
|
// TODO: This is kinda ugly, done on every frame...
|
|
char temp[256];
|
|
- if (System_GetPropertyBool(SYSPROP_APP_GOLD)) {
|
|
- snprintf(temp, sizeof(temp), "PPSSPP Gold %s", PPSSPP_GIT_VERSION);
|
|
- } else {
|
|
- snprintf(temp, sizeof(temp), "PPSSPP %s", PPSSPP_GIT_VERSION);
|
|
- }
|
|
+ snprintf(temp, sizeof(temp), "PPSSPP %s", PPSSPP_GIT_VERSION);
|
|
credits[0] = (const char *)temp;
|
|
|
|
UIContext &dc = *screenManager()->getUIContext();
|
|
diff --git a/UWP/PPSSPP_UWPMain.cpp b/UWP/PPSSPP_UWPMain.cpp
|
|
index 29afda806..b7028fc0c 100644
|
|
--- a/UWP/PPSSPP_UWPMain.cpp
|
|
+++ b/UWP/PPSSPP_UWPMain.cpp
|
|
@@ -426,12 +426,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
|
|
return false;
|
|
case SYSPROP_HAS_BACK_BUTTON:
|
|
return true;
|
|
- case SYSPROP_APP_GOLD:
|
|
-#ifdef GOLD
|
|
- return true;
|
|
-#else
|
|
- return false;
|
|
-#endif
|
|
case SYSPROP_CAN_JIT:
|
|
return true;
|
|
default:
|
|
diff --git a/Windows/MainWindowMenu.cpp b/Windows/MainWindowMenu.cpp
|
|
index 006fed4f4..4761171ff 100644
|
|
--- a/Windows/MainWindowMenu.cpp
|
|
+++ b/Windows/MainWindowMenu.cpp
|
|
@@ -136,7 +136,6 @@ namespace MainWindow {
|
|
|
|
const std::wstring visitMainWebsite = ConvertUTF8ToWString(des->T("www.ppsspp.org"));
|
|
const std::wstring visitForum = ConvertUTF8ToWString(des->T("PPSSPP Forums"));
|
|
- const std::wstring buyGold = ConvertUTF8ToWString(des->T("Buy Gold"));
|
|
const std::wstring gitHub = ConvertUTF8ToWString(des->T("GitHub"));
|
|
const std::wstring discord = ConvertUTF8ToWString(des->T("Discord"));
|
|
const std::wstring aboutPPSSPP = ConvertUTF8ToWString(des->T("About PPSSPP..."));
|
|
@@ -147,7 +146,6 @@ namespace MainWindow {
|
|
AppendMenu(helpMenu, MF_STRING | MF_BYCOMMAND, ID_HELP_OPENWEBSITE, visitMainWebsite.c_str());
|
|
AppendMenu(helpMenu, MF_STRING | MF_BYCOMMAND, ID_HELP_OPENFORUM, visitForum.c_str());
|
|
// Repeat the process for other languages, if necessary.
|
|
- AppendMenu(helpMenu, MF_STRING | MF_BYCOMMAND, ID_HELP_BUYGOLD, buyGold.c_str());
|
|
AppendMenu(helpMenu, MF_STRING | MF_BYCOMMAND, ID_HELP_GITHUB, gitHub.c_str());
|
|
AppendMenu(helpMenu, MF_STRING | MF_BYCOMMAND, ID_HELP_DISCORD, discord.c_str());
|
|
AppendMenu(helpMenu, MF_SEPARATOR, 0, 0);
|
|
@@ -1015,10 +1013,6 @@ namespace MainWindow {
|
|
ShellExecute(NULL, L"open", L"https://www.ppsspp.org/", NULL, NULL, SW_SHOWNORMAL);
|
|
break;
|
|
|
|
- case ID_HELP_BUYGOLD:
|
|
- ShellExecute(NULL, L"open", L"https://central.ppsspp.org/buygold", NULL, NULL, SW_SHOWNORMAL);
|
|
- break;
|
|
-
|
|
case ID_HELP_OPENFORUM:
|
|
ShellExecute(NULL, L"open", L"https://forums.ppsspp.org/", NULL, NULL, SW_SHOWNORMAL);
|
|
break;
|
|
@@ -1397,7 +1391,7 @@ namespace MainWindow {
|
|
{
|
|
W32Util::CenterWindow(hDlg);
|
|
HWND versionBox = GetDlgItem(hDlg, IDC_VERSION);
|
|
- std::string windowText = System_GetPropertyBool(SYSPROP_APP_GOLD) ? "PPSSPP Gold " : "PPSSPP ";
|
|
+ std::string windowText = "PPSSPP ";
|
|
windowText.append(PPSSPP_GIT_VERSION);
|
|
SetWindowText(versionBox, ConvertUTF8ToWString(windowText).c_str());
|
|
}
|
|
diff --git a/Windows/WindowsHost.cpp b/Windows/WindowsHost.cpp
|
|
index 610b79890..3d5926fce 100644
|
|
--- a/Windows/WindowsHost.cpp
|
|
+++ b/Windows/WindowsHost.cpp
|
|
@@ -155,11 +155,7 @@ void WindowsHost::ShutdownGraphics() {
|
|
}
|
|
|
|
void WindowsHost::SetWindowTitle(const char *message) {
|
|
-#ifdef GOLD
|
|
- const char *name = "PPSSPP Gold ";
|
|
-#else
|
|
const char *name = "PPSSPP ";
|
|
-#endif
|
|
std::wstring winTitle = ConvertUTF8ToWString(std::string(name) + PPSSPP_GIT_VERSION);
|
|
if (message != nullptr) {
|
|
winTitle.append(ConvertUTF8ToWString(" - "));
|
|
diff --git a/Windows/main.cpp b/Windows/main.cpp
|
|
index 9395233e2..90abec570 100644
|
|
--- a/Windows/main.cpp
|
|
+++ b/Windows/main.cpp
|
|
@@ -304,12 +304,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
|
|
return true;
|
|
case SYSPROP_HAS_BACK_BUTTON:
|
|
return true;
|
|
- case SYSPROP_APP_GOLD:
|
|
-#ifdef GOLD
|
|
- return true;
|
|
-#else
|
|
- return false;
|
|
-#endif
|
|
case SYSPROP_CAN_JIT:
|
|
return true;
|
|
default:
|
|
diff --git a/Windows/resource.h b/Windows/resource.h
|
|
index ce21b3a85..1f8002c10 100644
|
|
--- a/Windows/resource.h
|
|
+++ b/Windows/resource.h
|
|
@@ -322,7 +322,6 @@
|
|
// Dummy option to let the buffered rendering hotkey cycle through all the options.
|
|
#define ID_OPTIONS_BUFFEREDRENDERINGDUMMY 40500
|
|
#define IDC_STEPOUT 40501
|
|
-#define ID_HELP_BUYGOLD 40502
|
|
|
|
#define IDC_STATIC -1
|
|
|
|
diff --git a/android/jni/app-android.cpp b/android/jni/app-android.cpp
|
|
index df395e304..cebdf5804 100644
|
|
--- a/android/jni/app-android.cpp
|
|
+++ b/android/jni/app-android.cpp
|
|
@@ -458,12 +458,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
|
|
// Doesn't actually mean it's usable though, in many early versions of Android
|
|
// this dialog is complete garbage and only lets you select subfolders of the Downloads folder.
|
|
return androidVersion >= 21; // when ACTION_OPEN_DOCUMENT_TREE was added
|
|
- case SYSPROP_APP_GOLD:
|
|
-#ifdef GOLD
|
|
- return true;
|
|
-#else
|
|
- return false;
|
|
-#endif
|
|
case SYSPROP_CAN_JIT:
|
|
return true;
|
|
case SYSPROP_ANDROID_SCOPED_STORAGE:
|
|
diff --git a/ios/main.mm b/ios/main.mm
|
|
index e53b7c7ab..fe69647ed 100644
|
|
--- a/ios/main.mm
|
|
+++ b/ios/main.mm
|
|
@@ -148,12 +148,6 @@ bool System_GetPropertyBool(SystemProperty prop) {
|
|
switch (prop) {
|
|
case SYSPROP_HAS_BACK_BUTTON:
|
|
return false;
|
|
- case SYSPROP_APP_GOLD:
|
|
-#ifdef GOLD
|
|
- return true;
|
|
-#else
|
|
- return false;
|
|
-#endif
|
|
case SYSPROP_CAN_JIT:
|
|
return g_jitAvailable;
|
|
|
|
--
|
|
2.34.0
|
|
|