mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
95024494f3
* gnu/packages/games.scm (bsd-games): New variable. New patches, taken from Arch and Debian: * gnu/packages/patches/bsd-games-2.17-64bit.patch * gnu/packages/patches/bsd-games-bad-ntohl-cast.patch * gnu/packages/patches/bsd-games-gamescreen.h.patch * gnu/packages/patches/bsd-games-getline.patch * gnu/packages/patches/bsd-games-null-check.patch * gnu/packages/patches/bsd-games-number.c-and-test.patch * gnu/packages/patches/bsd-games-prevent-name-collisions.patch * gnu/packages/patches/bsd-games-stdio.h.patch New patches with our customizations (configure-config built after Arch's): * gnu/packages/patches/bsd-games-add-configure-config.patch * gnu/packages/patches/bsd-games-add-wrapper.patch * gnu/packages/patches/bsd-games-dont-install-empty-files.patch Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
14 lines
798 B
Diff
14 lines
798 B
Diff
--- a/dab/gamescreen.h 2004-01-02 23:34:51.000000000 +0530
|
|
+++ b/dab/gamescreen.h 2008-07-31 23:45:19.000000000 +0530
|
|
@@ -70,9 +70,9 @@
|
|
virtual void redraw(void) = 0; // Refresh
|
|
virtual int getinput(void) = 0; // Get user input
|
|
virtual void bell(void) = 0; // Beep
|
|
- virtual void score(size_t p, const PLAYER& p) = 0; // Post current score
|
|
- virtual void games(size_t p, const PLAYER& p) = 0; // Post games won
|
|
- virtual void total(size_t p, const PLAYER& p) = 0; // Post total score
|
|
+ virtual void score(size_t, const PLAYER&) = 0; // Post current score
|
|
+ virtual void games(size_t, const PLAYER&) = 0; // Post games won
|
|
+ virtual void total(size_t, const PLAYER&) = 0; // Post total score
|
|
virtual void ties(const PLAYER& p) = 0; // Post tie games
|
|
};
|