mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
298b349a05
* gnu/packages/kde-pim.scm (KDE PIM): Update to 21.12.3. (akonadi, akonadi-calendar, akonadi-contacts, akonadi-mime, akonadi-notes, akonadi-search, kaddressbook, kalarmcal, kcalendarsupport, kcalutils, kdepim-runtime, keventviews, kgpg, kidentitymanagement, kimap, kincidenceeditor, kldap, kleopatra, kmail, kmailcommon, kmailimporter, kmailtransport, kmbox, kmessagelib, kmime, knotes, kontactinterface, korganizer, kpeoplevcard, kpimcommon, kpimtextedit, ksmtp, ktnef, libgravatar, libkdepim, libkgapi, libkleo, libksieve): Update to 21.12.3. (kblog): Update to 20.04.3. * gnu/packages/patches/akonadi-not-relocatable.patch * gnu/packages/patches/akonadi-paths.patch * gnu/packages/patches/akonadi-timestamps.patch Fix patches to apply to latest code. (akonadi-calendar): [inputs]: Add new dependencies. (akonadi-contacts): [inputs]: Add new dependencies. (akonadi-search): [arguments]: Disable failing tests. (kcalendarsupport): [inputs]: Add new dependency, remove obsolete kdepim-apps-lib. (libksieve): [arguments]: Enable test that works now. * gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch: Fix patch. (kaddressbook): [inputs]: Remove obsolete kdepim-apps-libs. Move kdocstools to native-inputs. (kmessagelib): [inputs]: Remove obsolete kdepim-appslibs, add kguiaddons. [arguments]: Fix findind header file. (kmailimporter): [inputs]: Add new dependencies. (kmailtransport): [inputs]: Add qtkeychain. (knotes): [inputs]: Move kdocstools to native-inputs. (kincidenceeditor): [inputs]: Add new dependencies. Remove obsolete kdepim-apps-libs [arguments]: Disable failing test. (kldap): [inputs]: Add qtkeychain. (kgpg)[arguments]: Disable failing tests. (libkleo): [propagated-inputs]: Propagate gpgme, qgpgme. [arguments]: Disable failing tests. (kdepim-runtime): [inputs]: Add new dependencies grantlee, grantleetheme, kcmutils, kldap, libkdepim, qtkeychain [arguments]: Enable all the tests that pass. We need to use the old hack instead of search-input-directory to workaround a mysterious include error. (kdepim-apps-lib): Remove obsolete package. (kmail): [origin]: Remove patch. Don't think it is needed anymore. [inputs]: Add new dependencies, delete obsolete kdepim-apps-libs and duplicate kmime. [arguments]: Disable failing tests. * gnu/packages/patches/kmail-Fix-missing-link-libraries.patch: Delete file. * gnu/local.mk: Remove reference to patch. (kmailcommon): [inputs]: Add new dependencies. Signed-off-by: Marius Bakke <marius@gnu.org>
48 lines
2.5 KiB
Diff
48 lines
2.5 KiB
Diff
This is based on the respectve patch from NixPkgs, but with the parts pinning
|
|
mysql and postgresql executables removed. See our package definition on why.
|
|
|
|
diff --git a/src/akonadicontrol/agentmanager.cpp b/src/akonadicontrol/agentmanager.cpp
|
|
--- a/src/akonadicontrol/agentmanager.cpp
|
|
+++ b/src/akonadicontrol/agentmanager.cpp
|
|
@@ -47,7 +47,7 @@ public:
|
|
connect(this, &Akonadi::ProcessControl::unableToStart, this, []() {
|
|
QCoreApplication::instance()->exit(255);
|
|
});
|
|
- start(QStringLiteral("akonadiserver"), args, RestartOnCrash);
|
|
+ start(QStringLiteral(NIX_OUT "/bin/akonadiserver"), args, RestartOnCrash);
|
|
}
|
|
|
|
~StorageProcessControl() override
|
|
@@ -69,7 +69,7 @@ public:
|
|
connect(this, &Akonadi::ProcessControl::unableToStart, this, []() {
|
|
qCCritical(AKONADICONTROL_LOG) << "Failed to start AgentServer!";
|
|
});
|
|
- start(QStringLiteral("akonadi_agent_server"), args, RestartOnCrash);
|
|
+ start(QStringLiteral(NIX_OUT "/bin/akonadi_agent_server"), args, RestartOnCrash);
|
|
}
|
|
|
|
~AgentServerProcessControl() override
|
|
diff --git a/src/akonadicontrol/agentprocessinstance.cpp b/src/akonadicontrol/agentprocessinstance.cpp
|
|
--- a/src/akonadicontrol/agentprocessinstance.cpp
|
|
+++ b/src/akonadicontrol/agentprocessinstance.cpp
|
|
@@ -62,7 +62,7 @@ bool AgentProcessInstance::start(const AgentType &agentInfo)
|
|
} else {
|
|
Q_ASSERT(agentInfo.launchMethod == AgentType::Launcher);
|
|
const QStringList arguments = QStringList() << executable << identifier();
|
|
- const QString agentLauncherExec = Akonadi::StandardDirs::findExecutable(QStringLiteral("akonadi_agent_launcher"));
|
|
+ const QString agentLauncherExec = QLatin1String(NIX_OUT "/bin/akonadi_agent_launcher");
|
|
mController->start(agentLauncherExec, arguments);
|
|
}
|
|
return true;
|
|
diff --git a/src/server/storage/dbconfigmysql.cpp b/src/server/storage/dbconfigmysql.cpp
|
|
--- a/src/server/storage/dbconfigmysql.cpp
|
|
+++ b/src/server/storage/dbconfigmysql.cpp
|
|
@@ -215,7 +215,7 @@ bool DbConfigMysql::startInternalServer()
|
|
#endif
|
|
|
|
// generate config file
|
|
- const QString globalConfig = StandardDirs::locateResourceFile("config", QStringLiteral("mysql-global.conf"));
|
|
+ const QString globalConfig = QLatin1String(NIX_OUT "/etc/xdg/akonadi/mysql-global.conf");
|
|
const QString localConfig = StandardDirs::locateResourceFile("config", QStringLiteral("mysql-local.conf"));
|
|
const QString actualConfig = StandardDirs::saveDir("data") + QLatin1String("/mysql.conf");
|
|
if (globalConfig.isEmpty()) {
|