mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
13d858413c
* gnu/packages/glib.scm (gobject-introspection): Update to 1.72.0. * gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch, gnu/packages/patches/gobject-introspection-cc.patch: Rebase.
15 lines
537 B
Diff
15 lines
537 B
Diff
Use gcc as the default C compiler if CC is not set.
|
|
|
|
diff --git a/giscanner/__init__.py b/giscanner/__init__.py
|
|
index 7c2f365a..607fe341 100644
|
|
--- a/giscanner/__init__.py
|
|
+++ b/giscanner/__init__.py
|
|
@@ -21,6 +21,8 @@ import os
|
|
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
|
|
if builddir is not None:
|
|
__path__.append(os.path.join(builddir, 'giscanner')) # type: ignore # mypy issue #1422
|
|
+if not 'CC' in os.environ:
|
|
+ os.environ['CC'] = 'gcc'
|
|
try:
|
|
from ._version import __version__
|
|
except ImportError:
|