mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
3ba23f0582
* gnu/packages/patches/guile-2.2-default-utf8.patch: New file, extracted from
commit 2acfe022a7
.
* gnu/packages/patches/guile-3.0-linux-syscalls.patch,
gnu/packages/patches/guile-3.0-relocatable.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly. Move all Guile patches
together while at it.
* gnu/packages/make-bootstrap.scm (%guile-3.0-static-stripped): New public variable.
69 lines
2.5 KiB
Diff
69 lines
2.5 KiB
Diff
This patch changes Guile to use a default search path relative to the
|
|
location of the `guile' binary, allowing it to be relocated.
|
|
|
|
diff --git a/libguile/load.c b/libguile/load.c
|
|
--- a/libguile/load.c
|
|
+++ b/libguile/load.c
|
|
@@ -27,6 +27,7 @@
|
|
#include <stat-time.h>
|
|
#include <string.h>
|
|
#include <stdio.h>
|
|
+#include <libgen.h>
|
|
#include <sys/types.h>
|
|
#include <sys/stat.h>
|
|
#include <unistd.h>
|
|
@@ -334,6 +335,32 @@ scm_init_load_path ()
|
|
SCM cpath = SCM_EOL;
|
|
|
|
#ifdef SCM_LIBRARY_DIR
|
|
+ char *program, *bin_dir, *prefix, *module_dir, *ccache_dir;
|
|
+
|
|
+ /* Determine the source and compiled module directories at run-time,
|
|
+ relative to the executable's location.
|
|
+
|
|
+ Note: Use /proc/self/exe instead of argv[0] because the latter is
|
|
+ not necessarily an absolute, nor a valid file name. */
|
|
+
|
|
+ program = scm_gc_malloc_pointerless (256, "string");
|
|
+ readlink ("/proc/self/exe", program, 256);
|
|
+
|
|
+ bin_dir = dirname (strdupa (program));
|
|
+
|
|
+ prefix = scm_gc_malloc_pointerless (strlen (bin_dir) + 4, "string");
|
|
+ strcpy (prefix, bin_dir);
|
|
+ strcat (prefix, "/..");
|
|
+ prefix = canonicalize_file_name (prefix);
|
|
+
|
|
+ module_dir = scm_gc_malloc_pointerless (strlen (prefix) + 50, "string");
|
|
+ strcpy (module_dir, prefix);
|
|
+ strcat (module_dir, "/share/guile/" SCM_EFFECTIVE_VERSION);
|
|
+
|
|
+ ccache_dir = scm_gc_malloc_pointerless (strlen (prefix) + 50, "string");
|
|
+ strcpy (ccache_dir, prefix);
|
|
+ strcat (ccache_dir, "/lib/guile/" SCM_EFFECTIVE_VERSION "/ccache");
|
|
+
|
|
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_PATH"));
|
|
if (env && strcmp (env, "") == 0)
|
|
/* special-case interpret system-path=="" as meaning no system path instead
|
|
@@ -342,10 +369,7 @@ scm_init_load_path ()
|
|
else if (env)
|
|
path = scm_parse_path (scm_from_locale_string (env), path);
|
|
else
|
|
- path = scm_list_4 (scm_from_utf8_string (SCM_LIBRARY_DIR),
|
|
- scm_from_utf8_string (SCM_SITE_DIR),
|
|
- scm_from_utf8_string (SCM_GLOBAL_SITE_DIR),
|
|
- scm_from_utf8_string (SCM_PKGDATA_DIR));
|
|
+ path = scm_list_1 (scm_from_locale_string (module_dir));
|
|
|
|
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_COMPILED_PATH"));
|
|
if (env && strcmp (env, "") == 0)
|
|
@@ -355,8 +379,7 @@ scm_init_load_path ()
|
|
cpath = scm_parse_path (scm_from_locale_string (env), cpath);
|
|
else
|
|
{
|
|
- cpath = scm_list_2 (scm_from_utf8_string (SCM_CCACHE_DIR),
|
|
- scm_from_utf8_string (SCM_SITE_CCACHE_DIR));
|
|
+ cpath = scm_list_1 (scm_from_locale_string (ccache_dir));
|
|
}
|
|
|
|
#endif /* SCM_LIBRARY_DIR */
|