mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
31d289a475
Non-exhaustively fixes CVE-2016-9844, CVE-2018-1000035, CVE-2018-18384, and CVE-2019-13232. * gnu/packages/patches/unzip-COVSCAN-fix-unterminated-string.patch, gnu/packages/patches/unzip-CVE-2016-9844.patch, gnu/packages/patches/unzip-CVE-2018-1000035.patch, gnu/packages/patches/unzip-CVE-2018-18384.patch, gnu/packages/patches/unzip-case-insensitive.patch, gnu/packages/patches/unzip-alt-iconv-utf8-print.patch, gnu/packages/patches/unzip-alt-iconv-utf8.patch, gnu/packages/patches/unzip-close.patch, gnu/packages/patches/unzip-exec-shield.patch, gnu/packages/patches/unzip-fix-recmatch.patch, gnu/packages/patches/unzip-manpage-fix.patch, gnu/packages/patches/unzip-overflow.patch, gnu/packages/patches/unzip-symlink.patch, gnu/packages/patches/unzip-timestamp.patch, gnu/packages/patches/unzip-valgrind.patch, gnu/packages/patches/unzip-x-option.patch, gnu/packages/patches/unzip-zipbomb-manpage.patch, gnu/packages/patches/unzip-zipbomb-part1.patch, gnu/packages/patches/unzip-zipbomb-part2.patch, gnu/packages/patches/unzip-zipbomb-part3.patch: New patches. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/compression.scm (unzip/fixed): New variable. Apply patches. (unzip)[replacement]: Graft.
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
From 754137e70cf58a64ad524b704a86b651ba0cde07 Mon Sep 17 00:00:00 2001
|
|
From: Petr Stodulka <pstodulk@redhat.com>
|
|
Date: Wed, 14 Dec 2016 16:30:36 +0100
|
|
Subject: [PATCH] Fix CVE-2016-9844 (rhbz#1404283)
|
|
|
|
Fixes buffer overflow in zipinfo in similar way like fix for
|
|
CVE-2014-9913 provided by upstream.
|
|
---
|
|
zipinfo.c | 14 +++++++++++++-
|
|
1 file changed, 13 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/zipinfo.c b/zipinfo.c
|
|
index c03620e..accca2a 100644
|
|
--- a/zipinfo.c
|
|
+++ b/zipinfo.c
|
|
@@ -1984,7 +1984,19 @@ static int zi_short(__G) /* return PK-type error code */
|
|
ush dnum=(ush)((G.crec.general_purpose_bit_flag>>1) & 3);
|
|
methbuf[3] = dtype[dnum];
|
|
} else if (methnum >= NUM_METHODS) { /* unknown */
|
|
- sprintf(&methbuf[1], "%03u", G.crec.compression_method);
|
|
+ /* 2016-12-05 SMS.
|
|
+ * https://launchpad.net/bugs/1643750
|
|
+ * Unexpectedly large compression methods overflow
|
|
+ * &methbuf[]. Use the old, three-digit decimal format
|
|
+ * for values which fit. Otherwise, sacrifice the "u",
|
|
+ * and use four-digit hexadecimal.
|
|
+ */
|
|
+ if (G.crec.compression_method <= 999) {
|
|
+ sprintf( &methbuf[ 1], "%03u", G.crec.compression_method);
|
|
+ } else {
|
|
+ sprintf( &methbuf[ 0], "%04X", G.crec.compression_method);
|
|
+ }
|
|
+
|
|
}
|
|
|
|
for (k = 0; k < 15; ++k)
|
|
--
|
|
2.5.5
|
|
|