mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
b5ffcbe1af
* gnu/packages/fribidi.scm (bidiv): New variable. * gnu/packages/patches/bidiv-update-fribidi.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
50 lines
1.5 KiB
Diff
50 lines
1.5 KiB
Diff
https://sources.debian.org/data/main/b/bidiv/1.5-6/debian/patches/fribidi_019
|
|
|
|
Description: Fix building with fribidi 1.9
|
|
Author: أحمد المحمودي <aelmahmoudy@users.sourceforge.net>
|
|
Bug-Debian: http://bugs.debian.org/568130
|
|
|
|
--- a/bidiv.c
|
|
+++ b/bidiv.c
|
|
@@ -141,8 +141,9 @@ bidiv(FILE *fp)
|
|
*/
|
|
if(c1<0x80||c1>0xbf){
|
|
ungetc(c1, fp);
|
|
- unicode_in[len]=
|
|
- fribidi_iso8859_8_to_unicode_c(c);
|
|
+ fribidi_charset_to_unicode(
|
|
+ FRIBIDI_CHAR_SET_ISO8859_8,
|
|
+ &c, 1, &unicode_in[len]);
|
|
} else
|
|
unicode_in[len]=((c & 037) << 6) + (c1 & 077);
|
|
newline=0;
|
|
@@ -153,8 +154,9 @@ bidiv(FILE *fp)
|
|
In the future we will have a language
|
|
option, which will control this (as well
|
|
as the output encoding). */
|
|
- unicode_in[len]=
|
|
- fribidi_iso8859_8_to_unicode_c(c);
|
|
+ fribidi_charset_to_unicode(
|
|
+ FRIBIDI_CHAR_SET_ISO8859_8,
|
|
+ &c, 1, &unicode_in[len]);
|
|
#else
|
|
in[len]=c;
|
|
#endif
|
|
@@ -206,11 +208,11 @@ bidiv(FILE *fp)
|
|
rtl_line=0;
|
|
|
|
if(out_utf8)
|
|
- fribidi_unicode_to_utf8(unicode_out, len,
|
|
- out);
|
|
+ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8,
|
|
+ unicode_out, len, out);
|
|
else
|
|
- fribidi_unicode_to_iso8859_8(unicode_out, len,
|
|
- out);
|
|
+ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_ISO8859_8,
|
|
+ unicode_out, len, out);
|
|
/* if rtl_line (i.e., base_dir is RL), and we didn't fill the
|
|
entire width, we need to pad with spaces. Maybe in the
|
|
future this should be an option.
|
|
--
|
|
|