mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
8f9fdd31bd
* gnu/packages/syndication.scm (giara): New variable. * gnu/packages/patches/giara-fix-login.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
27 lines
858 B
Diff
27 lines
858 B
Diff
From f4adc1f52d777cea3331b4acae0c3bdec4d0eb70 Mon Sep 17 00:00:00 2001
|
|
From: Paper <paper@tilde.institute>
|
|
Date: Fri, 12 Mar 2021 21:10:34 +0000
|
|
Subject: [PATCH] fix login by removing everything after # from URL
|
|
|
|
---
|
|
giara/__main__.py | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/giara/__main__.py b/giara/__main__.py
|
|
index 10b9ae2..d235332 100644
|
|
--- a/giara/__main__.py
|
|
+++ b/giara/__main__.py
|
|
@@ -53,8 +53,9 @@ class GApplication(Gtk.Application):
|
|
def open(self, app, files, *args):
|
|
target = files[0].get_uri()
|
|
print(target)
|
|
+ code = target.split('=')[-1].split('#')[0]
|
|
get_authorized_client(
|
|
- reddit=self._unauth_reddit, code=target.split('=')[-1]
|
|
+ reddit=self._unauth_reddit, code=code
|
|
)
|
|
self.continue_activate(self._unauth_reddit)
|
|
|
|
--
|
|
GitLab
|
|
|