mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
6504587168
* gnu/packages/patches/zig-disable-libc-note-test.patch: Move patch changes to new file. * gnu/packages/patches/zig-use-system-paths.patch: Update line numbers. * gnu/packages/zig.scm: Update to 0.9.0 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
31 lines
1.3 KiB
Diff
31 lines
1.3 KiB
Diff
This test fails with "error.CompilationIncorrectlySucceeded".
|
|
|
|
diff --git a/test/compile_errors.zig b/test/compile_errors.zig
|
|
index b1eaa0302..621f9db0a 100644
|
|
--- a/test/compile_errors.zig
|
|
+++ b/test/compile_errors.zig
|
|
@@ -2943,15 +2943,15 @@ pub fn addCases(ctx: *TestContext) !void {
|
|
"tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
|
|
});
|
|
|
|
- ctx.testErrStage1("libc headers note",
|
|
- \\const c = @cImport(@cInclude("stdio.h"));
|
|
- \\export fn entry() void {
|
|
- \\ _ = c.printf("hello, world!\n");
|
|
- \\}
|
|
- , &[_][]const u8{
|
|
- "tmp.zig:1:11: error: C import failed",
|
|
- "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
|
|
- });
|
|
+ // ctx.testErrStage1("libc headers note",
|
|
+ // \\const c = @cImport(@cInclude("stdio.h"));
|
|
+ // \\export fn entry() void {
|
|
+ // \\ _ = c.printf("hello, world!\n");
|
|
+ // \\}
|
|
+ // , &[_][]const u8{
|
|
+ // "tmp.zig:1:11: error: C import failed",
|
|
+ // "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
|
|
+ // });
|
|
}
|
|
|
|
ctx.testErrStage1("comptime vector overflow shows the index",
|