mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
2468ca0488
* gnu/packages/admin.scm (thefuck): Update to 3.25 [inputs]: Add python-pyte. [native-inputs]: Remove python-setuptools. * gnu/packages/patches/thefuck-test-environ.patch: Adjust to latest source.
14 lines
490 B
Diff
14 lines
490 B
Diff
Retain environment setting of "HOME" for tests that need os.path.expanduser()
|
|
to return a readable directory in the build chroot.
|
|
|
|
--- thefuck-3.25/tests/conftest.py
|
|
+++ thefuck-3.25/tests/conftest.py
|
|
@@ -64,6 +64,7 @@ def set_shell(monkeypatch):
|
|
|
|
@pytest.fixture(autouse=True)
|
|
def os_environ(monkeypatch):
|
|
- env = {'PATH': os.environ['PATH']}
|
|
+ env = {'PATH': os.environ['PATH'],
|
|
+ 'HOME': os.environ['HOME']}
|
|
monkeypatch.setattr('os.environ', env)
|
|
return env
|