mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
1badc85068
* gnu/packages/patches/ceph-skip-unittest_blockdev.patch: Adjust for 13.2.2. * gnu/packages/patches/ceph-rocksdb-compat.patch: Delete file. * gnu/packages/patches/ceph-detect-rocksdb.patch, gnu/packages/patches/ceph-volume-respect-PATH.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/storage.scm (ceph): Update to 13.2.2. [source]: Don't remove src/dpdk, which has been moved to src/spdk/dpdk and is purged elsewhere. Drop bundled rapidjson. Adjust patch list. [arguments]: Add "-DWITH_MGR_DASHBOARD_FRONTEND=OFF" and "-DWITH_SPDK=OFF" to #:configure-flags. Drop obsolete "-DWITH_EMBEDDED". Add workaround for <https://bugs.gnu.org/30756>. Remove obsolete test substitution. Rework 'wrap-python-script' to be less verbose and wrap more scripts. [native-inputs]: Add GCC-7. [inputs]: Add OATH-TOOLKIT, RAPIDJSON and PYTHON2-SIX.
24 lines
753 B
Diff
24 lines
753 B
Diff
This test tries to walk a sysfs path and hits a null pointer exception.
|
|
|
|
/tmp/guix-build-ceph-12.0.0.drv-0/ceph-12.0.0/src/test/common/test_blkdev.cc:32: Failure
|
|
Expected: (dir) != (nullptr), actual: NULL vs 8-byte object <00-00 00-00 00-00 00-00>
|
|
|
|
diff --git a/src/test/common/CMakeLists.txt b/src/test/common/CMakeLists.txt
|
|
--- a/src/test/common/CMakeLists.txt
|
|
+++ b/src/test/common/CMakeLists.txt
|
|
@@ -12,15 +12,6 @@
|
|
${CMAKE_DL_LIBS}
|
|
)
|
|
|
|
-if(HAVE_BLKID)
|
|
- # unittest_blkdev
|
|
- add_executable(unittest_blkdev
|
|
- test_blkdev.cc
|
|
- )
|
|
- add_ceph_unittest(unittest_blkdev)
|
|
- target_link_libraries(unittest_blkdev ceph-common ${BLKID_LIBRARIES})
|
|
-endif()
|
|
-
|
|
# unittest_bloom_filter
|
|
add_executable(unittest_bloom_filter
|
|
test_bloom_filter.cc
|