mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 03:15:09 -05:00
ee6bb0cc76
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xml.scm (libxml2)[source]: Add patches.
33 lines
917 B
Diff
33 lines
917 B
Diff
From ba58f23c60862f2158b457f4d30031761bf4dde1 Mon Sep 17 00:00:00 2001
|
|
From: Nick Wellnhofer <wellnhofer@aevum.de>
|
|
Date: Sun, 8 Mar 2015 16:44:11 +0100
|
|
Subject: [PATCH] Fix order of root nodes
|
|
|
|
Make sure root nodes are sorted before other nodes.
|
|
---
|
|
xpath.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/xpath.c b/xpath.c
|
|
index ffd2a48..e9f5bf9 100644
|
|
--- a/xpath.c
|
|
+++ b/xpath.c
|
|
@@ -361,13 +361,13 @@ turtle_comparison:
|
|
/*
|
|
* compute depth to root
|
|
*/
|
|
- for (depth2 = 0, cur = node2;cur->parent != NULL;cur = cur->parent) {
|
|
+ for (depth2 = 0, cur = node2; cur != NULL; cur = cur->parent) {
|
|
if (cur == node1)
|
|
return(1);
|
|
depth2++;
|
|
}
|
|
root = cur;
|
|
- for (depth1 = 0, cur = node1;cur->parent != NULL;cur = cur->parent) {
|
|
+ for (depth1 = 0, cur = node1; cur != NULL; cur = cur->parent) {
|
|
if (cur == node2)
|
|
return(-1);
|
|
depth1++;
|
|
--
|
|
2.6.3
|
|
|