mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
5d53eec337
* gnu/packages/ebook.scm (calibre): Update to 5.14.0. [source]: Adjust the snippet to preserve some files used by the HTML reader. [native-inputs]: Add python-pyqt-builder. Replace python2-flake8 with python-flake8. [inputs]: Remove chmlib, js-mathjax, python-chardet, and python-sip. Add python-cchardet, python-speechd, python-zeroconf, python-py7zr, python-pychm, python-pycryptodome, libjpeg, and libjxr. Replace all Python 2 dependencies with their Python 3 equivalents. [arguments]: Build with the default Python and adjust custom phases accordingly. Adjust the 'configure' phase to changes in how Calibre uses SIP, and patch lookup paths for libjpeg and libjxr. Rename the 'build-extra' phase to 'install-rapydscript', and run it after the 'install' phase. Adjust it for Calibre 5.14.0. * gnu/packages/patches/calibre-no-updates-dialog.patch, gnu/packages/patches/calibre-remove-test-sqlite.patch, gnu/packages/patches/calibre-remove-test-unrar.patch: Adjust patches for Calibre 5.14.0.
28 lines
968 B
Diff
28 lines
968 B
Diff
From d8225e83c3b73f0e0da73874910f50ca652f48cf Mon Sep 17 00:00:00 2001
|
|
From: Brendan Tildesley <mail@brendan.scot>
|
|
Date: Thu, 25 Feb 2021 00:48:00 +1100
|
|
Subject: [PATCH] Remove test_sqlite
|
|
|
|
---
|
|
src/calibre/test_build.py | 6 ------
|
|
1 file changed, 6 deletions(-)
|
|
|
|
diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
|
|
index 0ab7aa0646..87fdfabd9a 100644
|
|
--- a/src/calibre/test_build.py
|
|
+++ b/src/calibre/test_build.py
|
|
@@ -273,12 +273,6 @@ def read_changes():
|
|
m.close()
|
|
self.assertEqual(winutil.parse_cmdline('"c:\\test exe.exe" "some arg" 2'), ('c:\\test exe.exe', 'some arg', '2'))
|
|
|
|
- def test_sqlite(self):
|
|
- import sqlite3
|
|
- conn = sqlite3.connect(':memory:')
|
|
- from calibre.library.sqlite import load_c_extensions
|
|
- self.assertTrue(load_c_extensions(conn, True), 'Failed to load sqlite extension')
|
|
-
|
|
def test_apsw(self):
|
|
import apsw
|
|
conn = apsw.Connection(':memory:')
|
|
--
|
|
2.30.1
|