mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
8d653c08b7
* gnu/packages/llvm.scm (%llvm-monorepo-hashes): Adjust for 14.0.4. (%llvm-patches): Likewise. (llvm-14, clang-14, lld-14): Update to 14.0.4. * gnu/packages/patches/clang-14.0-libc-search-path.patch: Adjust for upstream changes.
95 lines
3.8 KiB
Diff
95 lines
3.8 KiB
Diff
Clang attempts to guess file names based on the OS and distro (yes!),
|
|
but unfortunately, that doesn't work for us.
|
|
|
|
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
|
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
|
the distro-specific stuff and removes the hard-coded FHS directory names
|
|
to make sure Clang also works on foreign distros.
|
|
|
|
diff --git a/clang/lib/Driver/Distro.cpp b/clang/lib/Driver/Distro.cpp
|
|
index 5ac38c34d112..2a704b418fdc 100644
|
|
--- a/clang/lib/Driver/Distro.cpp
|
|
+++ b/clang/lib/Driver/Distro.cpp
|
|
@@ -96,6 +96,10 @@ static Distro::DistroType DetectLsbRelease(llvm::vfs::FileSystem &VFS) {
|
|
}
|
|
|
|
static Distro::DistroType DetectDistro(llvm::vfs::FileSystem &VFS) {
|
|
+ // The compiler should always behave the same, even when used via Guix on a
|
|
+ // foreign distro.
|
|
+ return Distro::UnknownDistro;
|
|
+
|
|
Distro::DistroType Version = Distro::UnknownDistro;
|
|
|
|
// Newer freedesktop.org's compilant systemd-based systems
|
|
diff --git a/clang/lib/Driver/ToolChains/Cuda.cpp b/clang/lib/Driver/ToolChains/Cuda.cpp
|
|
index 4a9f6d4c4e3e..0ae13ebebd27 100644
|
|
--- a/clang/lib/Driver/ToolChains/Cuda.cpp
|
|
+++ b/clang/lib/Driver/ToolChains/Cuda.cpp
|
|
@@ -117,6 +117,9 @@ CudaInstallationDetector::CudaInstallationDetector(
|
|
const Driver &D, const llvm::Triple &HostTriple,
|
|
const llvm::opt::ArgList &Args)
|
|
: D(D) {
|
|
+ // Don't look for CUDA in /usr.
|
|
+ return;
|
|
+
|
|
struct Candidate {
|
|
std::string Path;
|
|
bool StrictChecking;
|
|
diff --git a/clang/lib/Driver/ToolChains/Linux.cpp b/clang/lib/Driver/ToolChains/Linux.cpp
|
|
index 83cb41159de7..6b920e33d1ef 100644
|
|
--- a/clang/lib/Driver/ToolChains/Linux.cpp
|
|
+++ b/clang/lib/Driver/ToolChains/Linux.cpp
|
|
@@ -186,6 +186,10 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
|
|
Generic_GCC::PushPPaths(PPaths);
|
|
|
|
+ // Comment out the distro-specific tweaks so that they don't bite when
|
|
+ // using Guix on a foreign distro.
|
|
+#if 0
|
|
+
|
|
Distro Distro(D.getVFS(), Triple);
|
|
|
|
if (Distro.IsAlpineLinux() || Triple.isAndroid()) {
|
|
@@ -250,6 +254,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
|
|
if (IsAndroid || Distro.IsOpenSUSE())
|
|
ExtraOpts.push_back("--enable-new-dtags");
|
|
+#endif
|
|
|
|
// The selection of paths to try here is designed to match the patterns which
|
|
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
|
@@ -270,6 +275,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
}
|
|
Generic_GCC::AddMultilibPaths(D, SysRoot, OSLibDir, MultiarchTriple, Paths);
|
|
|
|
+#if 0
|
|
addPathIfExists(D, SysRoot + "/lib/" + MultiarchTriple, Paths);
|
|
addPathIfExists(D, SysRoot + "/lib/../" + OSLibDir, Paths);
|
|
|
|
@@ -298,9 +304,11 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
addPathIfExists(D, SysRoot + "/" + OSLibDir + "/" + ABIName, Paths);
|
|
addPathIfExists(D, SysRoot + "/usr/" + OSLibDir + "/" + ABIName, Paths);
|
|
}
|
|
+#endif
|
|
|
|
Generic_GCC::AddMultiarchPaths(D, SysRoot, OSLibDir, Paths);
|
|
|
|
+#if 0
|
|
// The deprecated -DLLVM_ENABLE_PROJECTS=libcxx configuration installs
|
|
// libc++.so in D.Dir+"/../lib/". Detect this path.
|
|
// TODO Remove once LLVM_ENABLE_PROJECTS=libcxx is unsupported.
|
|
@@ -310,6 +318,14 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
|
|
addPathIfExists(D, SysRoot + "/lib", Paths);
|
|
addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
|
+#endif
|
|
+
|
|
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
|
+ // and friends can be found.
|
|
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
|
+
|
|
+ // Add GCC's lib/ directory so libstdc++.so can be found.
|
|
+ addPathIfExists(D, GCCInstallation.getParentLibPath(), Paths);
|
|
}
|
|
|
|
ToolChain::RuntimeLibType Linux::GetDefaultRuntimeLibType() const {
|