mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
b65a1e4a21
* gnu/packages/emacs.scm (emacs): Update to 28.1 * gnu/packages/patches/emacs-exec-path.patch: Adjust accordingly. * gnu/packages/patches/emacs-ignore-empty-xim-styles.patch: Delete file. * gnu/local.mk: Remove it here.
16 lines
811 B
Diff
16 lines
811 B
Diff
Do not capture the build-time value of $PATH in the 'emacs' executable
|
|
since this can noticeably increase the size of the closure of Emacs
|
|
with things like GCC being referenced.
|
|
|
|
--- a/lisp/loadup.el
|
|
+++ b/lisp/loadup.el
|
|
@@ -530,7 +530,8 @@ lost after dumping")))
|
|
((equal dump-mode "dump") "emacs")
|
|
((equal dump-mode "bootstrap") "emacs")
|
|
((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
|
|
- (t (error "Unrecognized dump mode %s" dump-mode)))))
|
|
+ (t (error "Unrecognized dump mode %s" dump-mode))))
|
|
+ (exec-path nil))
|
|
(when (and (featurep 'native-compile)
|
|
(equal dump-mode "pdump"))
|
|
;; Don't enable this before bootstrap is completed, as the
|