mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
4c610d2b2e
* gnu/packages/games.scm (fuzzylite): New variable. * gnu/packages/patches/fuzzylite-relative-path-in-tests.patch: New file. * gnu/packages/patches/fuzzylite-use-catch2.patch: New file. * gnu/packages/patches/fuzzylite-soften-float-equality.patch: New file. * gnu/local.mk (dist_patch_DATA): Register them here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
15 lines
614 B
Diff
15 lines
614 B
Diff
Workaround https://github.com/fuzzylite/fuzzylite/issues/85
|
|
|
|
diff --git a/fuzzylite/test/BenchmarkTest.cpp b/fuzzylite/test/BenchmarkTest.cpp
|
|
index f868ec29..464d394d 100644
|
|
--- a/fuzzylite/test/BenchmarkTest.cpp
|
|
+++ b/fuzzylite/test/BenchmarkTest.cpp
|
|
@@ -30,7 +30,7 @@ namespace fl {
|
|
}
|
|
|
|
TEST_CASE("Benchmarks from FLD files", "[benchmark][fld]") {
|
|
- std::string path = "../../examples/";
|
|
+ std::string path = "../examples/";
|
|
typedef std::pair<std::string, int > Example;
|
|
std::vector<Example> examples;
|
|
examples.push_back(Example("mamdani/AllTerms", int(1e4)));
|