mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
c18803f28d
This allows Gajim to find plug-ins installed with Guix. Reported at <http://issues.guix.gnu.org/44730>. However, at the time of pushing both packaged plug-ins (gajim-omemo and gajim-openpgp) require an unstable version of Gajim and will not load. * gnu/packages/messaging.scm (gajim)[arguments]: Replace the ‘add-plugin-dirs’ substitution phase with a... [source]: ...patch that won't silently break in the future. * gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
11 lines
575 B
Diff
11 lines
575 B
Diff
--- a/gajim/common/configpaths.py 2020-11-19 12:12:02.004414323 +0100
|
|
+++ a/gajim/common/configpaths.py 2020-11-19 15:34:52.211476895 +0100
|
|
@@ -47,7 +47,7 @@
|
|
return [Path(_paths['PLUGINS_BASE']),
|
|
Path('/app/plugins')]
|
|
return [Path(_paths['PLUGINS_BASE']),
|
|
- Path(_paths['PLUGINS_USER'])]
|
|
+ Path(_paths['PLUGINS_USER'])] + ([Path(os.getenv('GAJIM_PLUGIN_PATH'))] if os.getenv('GAJIM_PLUGIN_PATH') and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() else [])
|
|
|
|
|
|
def get_paths(type_: PathType) -> Generator[str, None, None]:
|