mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
c76d0201f7
* gnu/packages/animation.scm (gnash): New variable. * gnu/packages/patches/gnash-fix-giflib-version: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Christopher Baines <mail@cbaines.net>
17 lines
564 B
Diff
17 lines
564 B
Diff
Description: Change GIFLIB_MINOR to allow matching with v5.2+
|
|
Source: https://savannah.gnu.org/patch/index.php?9873
|
|
Author: marius851000
|
|
|
|
diff --git a/libbase/GnashImageGif.cpp b/libbase/GnashImageGif.cpp
|
|
index 2ae5ddb..b87b1e7 100644
|
|
--- a/libbase/GnashImageGif.cpp
|
|
+++ b/libbase/GnashImageGif.cpp
|
|
@@ -120,7 +120,7 @@ GifInput::GifInput(std::shared_ptr<IOChannel> in)
|
|
GifInput::~GifInput()
|
|
{
|
|
// Clean up allocated data.
|
|
-#if GIFLIB_MAJOR==5 && GIFLIB_MINOR==1
|
|
+#if GIFLIB_MAJOR==5 && GIFLIB_MINOR!=0
|
|
DGifCloseFile(_gif, 0);
|
|
#else
|
|
DGifCloseFile(_gif);
|