mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
15a96bd6e9
Icedove@115 does not properly work without this patch. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1843007 * gnu/packages/icu4c.scm (icu4c-73)[source]: Use patch. * gnu/packages/patches/icu4c-icu-22132-fix-vtimezone.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Change-Id: Ie64d1e33afedbaedbaafaeb607a201eb671ac7bd Change-Id: I6d753eacc7daac5663128b20a550044d0fd0ddb7
31 lines
1.3 KiB
Diff
31 lines
1.3 KiB
Diff
Source: https://unicode-org.atlassian.net/browse/ICU-22132?focusedCommentId=166752
|
|
Author: Sean Burke
|
|
License:
|
|
Fixes: https://bugzilla.mozilla.org/show_bug.cgi?id=1843007
|
|
|
|
diff --git a/icu4c/source/i18n/vtzone.cpp b/icu4c/source/i18n/vtzone.cpp
|
|
index 3035106701..5e738e11fa 100644
|
|
--- a/source/i18n/vtzone.cpp
|
|
+++ b/source/i18n/vtzone.cpp
|
|
@@ -1735,14 +1735,14 @@ VTimeZone::write(VTZWriter& writer, UErrorCode& status) const {
|
|
}
|
|
}
|
|
} else {
|
|
- UnicodeString icutzprop;
|
|
- UVector customProps(nullptr, uhash_compareUnicodeString, status);
|
|
+ UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
|
|
if (olsonzid.length() > 0 && icutzver.length() > 0) {
|
|
- icutzprop.append(olsonzid);
|
|
- icutzprop.append(u'[');
|
|
- icutzprop.append(icutzver);
|
|
- icutzprop.append(u']');
|
|
- customProps.addElement(&icutzprop, status);
|
|
+ LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
|
|
+ icutzprop->append(olsonzid);
|
|
+ icutzprop->append(u'[');
|
|
+ icutzprop->append(icutzver);
|
|
+ icutzprop->append(u']');
|
|
+ customProps.adoptElement(icutzprop.orphan(), status);
|
|
}
|
|
writeZone(writer, *tz, &customProps, status);
|
|
}
|