mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
a042bfcd7e
* gnu/packages/geo.scm (libgeotiff): [source]: Add patches to fix build with proj 9.3.1. * gnu/local.mk: Add patch files. * gnu/packages/patches/libgeotiff-fix-tests-on-i386.patch: New file. * gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.0.patch: New file. * gnu/packages/patches/libgeotiff-fix-tests-with-proj-9.3.1.patch: New file. Change-Id: I5f09e793698b0b137888faa0f595ef06850c6160 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
35 lines
1.7 KiB
Diff
35 lines
1.7 KiB
Diff
From 9990160268fafb71751d4f3a9ad724df70cb9451 Mon Sep 17 00:00:00 2001
|
|
From: Bas Couwenberg <sebastic@xs4all.nl>
|
|
Date: Fri, 1 Dec 2023 10:35:46 +0100
|
|
Subject: [PATCH] Fix test failure on i386.
|
|
|
|
---
|
|
https://github.com/OSGeo/libgeotiff/pull/107
|
|
|
|
test/testlistgeo | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/test/testlistgeo b/test/testlistgeo
|
|
index 48e92eb..ceec2e6 100755
|
|
--- a/test/testlistgeo
|
|
+++ b/test/testlistgeo
|
|
@@ -218,6 +218,9 @@ echo "" >>${OUT}
|
|
sed "s/ETRS89-extended/ETRS89/g" < ${OUT} > ${OUT}.tmp
|
|
mv ${OUT}.tmp ${OUT}
|
|
|
|
+sed "s/ProjCenterLongGeoKey: 46.437229 ( 46d26'14.02\"E)/ProjCenterLongGeoKey: 46.437229 ( 46d26'14.03\"E)/" < ${OUT} > ${OUT}.tmp
|
|
+mv ${OUT}.tmp ${OUT}
|
|
+
|
|
sed "s/ETRS89-extended/ETRS89/g" < ${TEST_CLI_DIR}/testlistgeo_out.dist > testlistgeo_out.dist.normalized
|
|
|
|
sed "s/GCS: 4053\/Unspecified datum based upon the International 1924 Authalic Sphere/GCS: 10346\/NSIDC Authalic Sphere/g" < ${OUT} > ${OUT}.tmp
|
|
@@ -230,6 +233,9 @@ mv testlistgeo_out.dist.normalized.tmp testlistgeo_out.dist.normalized
|
|
sed "s/Datum: 6053\/Not specified (based on International 1924 Authalic Sphere)/Datum: 1360\/NSIDC International 1924 Authalic Sphere/g" < testlistgeo_out.dist.normalized > testlistgeo_out.dist.normalized.tmp
|
|
mv testlistgeo_out.dist.normalized.tmp testlistgeo_out.dist.normalized
|
|
|
|
+sed "s/ProjCenterLongGeoKey: 46.437229 ( 46d26'14.02\"E)/ProjCenterLongGeoKey: 46.437229 ( 46d26'14.03\"E)/" < testlistgeo_out.dist.normalized > testlistgeo_out.dist.normalized.tmp
|
|
+mv testlistgeo_out.dist.normalized.tmp testlistgeo_out.dist.normalized
|
|
+
|
|
# do 'diff' with distribution results
|
|
# after cleaning for avoid spurios result due
|
|
# to different build dir
|