mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
3485984a09
* gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch, gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch: New files. * gnu/packages/llvm.scm (clang-runtime-3.7, llvm-3.7, llvm-3.8): Use patches. * gnu/local.mk: Register patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
15 lines
533 B
Diff
15 lines
533 B
Diff
Patch from https://github.com/digego/extempore/issues/318
|
|
|
|
diff --git a/include/llvm/IR/ValueMap.h.orig b/include/llvm/IR/ValueMap.h
|
|
index ad518ac..d928f6a 100644
|
|
--- a/include/llvm/IR/ValueMap.h
|
|
+++ b/include/llvm/IR/ValueMap.h
|
|
@@ -99,7 +99,7 @@
|
|
explicit ValueMap(const ExtraData &Data, unsigned NumInitBuckets = 64)
|
|
: Map(NumInitBuckets), Data(Data) {}
|
|
|
|
- bool hasMD() const { return MDMap; }
|
|
+ bool hasMD() const { return static_cast<bool>(MDMap); }
|
|
MDMapT &MD() {
|
|
if (!MDMap)
|
|
MDMap.reset(new MDMapT);
|