mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
79878c64b4
* gnu/packages/nss.scm (nss): Update to 3.66. Reindent.
[arguments]: Remove #:parallel-build?.
* gnu/packages/patches/nss-getcwd-nonnull.patch: Adjust for directory change.
* gnu/packages/patches/nss-3.56-pkgconfig.patch,
gnu/packages/patches/nss-increase-test-timeout.patch: Revert to
6223566971
.
* gnu/packages/certs.scm (nss-certs)[arguments]: Adjust for directory change.
30 lines
959 B
Diff
30 lines
959 B
Diff
Disable -Werror=nonnull on getcwd(0, 4096) because GCC incorrectly warns that
|
|
the second argument should be NULL with recent glibc. See:
|
|
|
|
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96832
|
|
https://sourceware.org/bugzilla/show_bug.cgi?id=26545
|
|
|
|
diff --git a/nss/coreconf/nsinstall/nsinstall.c b/nss/coreconf/nsinstall/nsinstall.c
|
|
--- a/nss/coreconf/nsinstall/nsinstall.c
|
|
+++ b/nss/coreconf/nsinstall/nsinstall.c
|
|
@@ -236,14 +236,20 @@ main(int argc, char **argv)
|
|
return 0;
|
|
|
|
if (!cwd) {
|
|
+#pragma GCC diagnostic push
|
|
+#pragma GCC diagnostic ignored "-Wnonnull"
|
|
cwd = GETCWD(0, PATH_MAX);
|
|
+#pragma GCC diagnostic pop
|
|
if (!cwd)
|
|
fail("could not get CWD");
|
|
}
|
|
|
|
/* make sure we can get into todir. */
|
|
xchdir(todir);
|
|
+#pragma GCC diagnostic push
|
|
+#pragma GCC diagnostic ignored "-Wnonnull"
|
|
todir = GETCWD(0, PATH_MAX);
|
|
+#pragma GCC diagnostic pop
|
|
if (!todir)
|
|
fail("could not get CWD in todir");
|
|
tdlen = strlen(todir);
|