mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
5594f4c999
* gnu/packages/sssd.scm (sssd): Update to 2.9.1. [native-inputs]: Add bc. * gnu/packages/patches/sssd-system-directories.patch: Adjust for new version. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
57 lines
1.8 KiB
Diff
57 lines
1.8 KiB
Diff
Do not attempt to create $localstatedir and $sysconfdir (i.e., /var and /etc)
|
|
upon "make install".
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index e780e8a14..afd2b0a49 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -84,7 +84,7 @@ pkgconfigdir = $(libdir)/pkgconfig
|
|
krb5rcachedir = @krb5rcachedir@
|
|
sudolibdir = @sudolibpath@
|
|
polkitdir = @polkitdir@
|
|
-pamconfdir = $(sysconfdir)/pam.d
|
|
+pamconfdir = $(prefix)/etc/pam.d
|
|
systemtap_tapdir = @tapset_dir@
|
|
sssdkcmdatadir = $(datadir)/sssd-kcm
|
|
deskprofilepath = $(sss_statedir)/deskprofile
|
|
@@ -5378,7 +5378,6 @@ installsssddirs::
|
|
$(DESTDIR)$(bindir) \
|
|
$(DESTDIR)$(sbindir) \
|
|
$(DESTDIR)$(mandir) \
|
|
- $(DESTDIR)$(pidpath) \
|
|
$(DESTDIR)$(pluginpath) \
|
|
$(DESTDIR)$(libdir)/ldb \
|
|
$(DESTDIR)$(dbuspolicydir) \
|
|
@@ -5388,24 +5387,12 @@ installsssddirs::
|
|
$(DESTDIR)$(sssddatadir) \
|
|
$(DESTDIR)$(sudolibdir) \
|
|
$(DESTDIR)$(autofslibdir) \
|
|
- $(DESTDIR)$(pipepath)/private \
|
|
$(DESTDIR)$(krb5snippetsdir) \
|
|
- $(SSSD_USER_DIRS) \
|
|
$(NULL);
|
|
if SSSD_USER
|
|
-chown $(SSSD_USER):$(SSSD_USER) $(SSSD_USER_DIRS)
|
|
-chown $(SSSD_USER) $(DESTDIR)$(pipepath)/private
|
|
endif
|
|
- $(INSTALL) -d -m 0700 $(DESTDIR)$(dbpath) $(DESTDIR)$(logpath) \
|
|
- $(DESTDIR)$(keytabdir) \
|
|
- $(NULL)
|
|
- $(INSTALL) -d -m 0750 $(DESTDIR)$(pipepath)/private
|
|
- $(INSTALL) -d -m 0755 $(DESTDIR)$(mcpath) $(DESTDIR)$(pipepath) \
|
|
- $(DESTDIR)$(pubconfpath) \
|
|
- $(DESTDIR)$(pubconfpath)/krb5.include.d $(DESTDIR)$(gpocachepath)
|
|
- $(INSTALL) -d -m 0711 $(DESTDIR)$(sssdconfdir) \
|
|
- $(DESTDIR)$(sssdconfdir)/conf.d \
|
|
- $(DESTDIR)$(sssdconfdir)/pki
|
|
|
|
if HAVE_DOXYGEN
|
|
docs:
|
|
@@ -5523,7 +5510,6 @@ if BUILD_SAMBA
|
|
endif
|
|
if BUILD_KCM
|
|
$(MKDIR_P) $(DESTDIR)/$(sssdkcmdatadir)
|
|
- $(MKDIR_P) $(DESTDIR)$(secdbpath)
|
|
endif
|
|
|
|
uninstall-hook:
|