guix/gnu/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch
Zhu Zihao f785299af1
gnu: flatpak: Do not leak GDK_PIXBUF_MODULE_FILE into the sandbox.
Fixes <https://issues.guix.gnu.org/54784>.

* gnu/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add corresponding entry.
* gnu/packages/package-management.scm (flatpak)[source]: Use patch.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2022-04-28 16:49:08 +02:00

19 lines
763 B
Diff

Most Guix system setup with desktop evironment will install GDK_PIXBUF_MODULE_FILE
environment variable in the system profile, and it'll be leaked into the sandbox
environment of flatpak, so the applications in sandbox may fail to find correct
GdkPixbuf loaders.
This patch unset the GDK_PIXBUF_MODULE_FILE environment variable before running
the sandboxed applications, prevents it to load GdkPixbuf loaders from the path
of host system.
--- a/common/flatpak-run.c
+++ b/common/flatpak-run.c
@@ -1853,6 +1853,7 @@ static const ExportData default_exports[] = {
{"GST_PTP_HELPER", NULL},
{"GST_PTP_HELPER_1_0", NULL},
{"GST_INSTALL_PLUGINS_HELPER", NULL},
+ {"GDK_PIXBUF_MODULE_FILE", NULL},
};
static const ExportData no_ld_so_cache_exports[] = {