mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
b97f549b14
Bump packages’ versions to the lastest Stackage or Hackage release. Since packages are interdependent, do so in a single commit. 525 packages have been updated. These packages have been removed, because they fail to build, have no newer version available and no dependencies: corrode ghc-easytest ghc-edisonapi ghc-edisoncore ghc-pandoc-types ghc-regex-tdfa-text These have been removed, because they are no longer required: ghc-happy-1.19.9 ghc-prettyprinter-1.6 ghc-protolude-0.3 ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc does not use them any more. Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
27 lines
961 B
Diff
27 lines
961 B
Diff
Compatibility with GHC 8.10 and template-haskell 2.16.
|
|
|
|
Taken from
|
|
https://raw.githubusercontent.com/archlinux/svntogit-community/packages/haskell-language-haskell-extract/trunk/ghc-8.10.patch
|
|
|
|
diff --git a/src/Language/Haskell/Extract.hs b/src/Language/Haskell/Extract.hs
|
|
index 3e8958b..43dfe04 100644
|
|
--- a/src/Language/Haskell/Extract.hs
|
|
+++ b/src/Language/Haskell/Extract.hs
|
|
@@ -1,3 +1,4 @@
|
|
+{-# LANGUAGE CPP #-}
|
|
module Language.Haskell.Extract (
|
|
functionExtractor,
|
|
functionExtractorMap,
|
|
@@ -25,7 +26,11 @@ extractAllFunctions pattern =
|
|
functionExtractor :: String -> ExpQ
|
|
functionExtractor pattern =
|
|
do functions <- extractAllFunctions pattern
|
|
- let makePair n = TupE [ LitE $ StringL n , VarE $ mkName n]
|
|
+ let makePair n = TupE
|
|
+#if MIN_VERSION_template_haskell(2,16,0)
|
|
+ $ map Just
|
|
+#endif
|
|
+ [ LitE $ StringL n , VarE $ mkName n]
|
|
return $ ListE $ map makePair functions
|
|
|
|
|