mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
f6b911fb5f
* gnu/packages/commencement.scm (glibc-mesboot0): Use Gash instead of coretutils&co.
30 lines
1 KiB
Diff
30 lines
1 KiB
Diff
We want to allow builds in chroots that lack /bin/sh. Thus, system(3)
|
|
and popen(3) need to be tweaked to use the right shell. For the bootstrap
|
|
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
|
|
instead uses the hard-coded absolute file name of `bash'.
|
|
|
|
--- a/sysdeps/posix/system.c
|
|
+++ b/sysdeps/posix/system.c
|
|
@@ -106,8 +106,8 @@ do_system (const char *line)
|
|
(void) UNBLOCK;
|
|
|
|
/* Exec the shell. */
|
|
- (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ);
|
|
+ (void) execvp (SHELL_NAME, (char *const *) new_argv);
|
|
_exit (127);
|
|
}
|
|
else if (pid < (pid_t) 0)
|
|
/* The fork failed. */
|
|
--- a/libio/iopopen.c
|
|
+++ b/libio/iopopen.c
|
|
@@ -170,7 +170,7 @@ _IO_new_proc_open (fp, command, mode)
|
|
for (p = proc_file_chain; p; p = p->next)
|
|
_IO_close (_IO_fileno ((_IO_FILE *) p));
|
|
|
|
- _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0);
|
|
+ execlp ("sh", "sh", "-c", command, (char *) 0);
|
|
_IO__exit (127);
|
|
}
|
|
_IO_close (child_end);
|
|
|
|
|