mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-14 19:05:10 -05:00
ad21d767df
Fixes CVE-2019-11757, CVE-2019-11759, CVE-2019-11760, CVE-2019-11761, CVE-2019-11762, CVE-2019-11763, CVE-2019-11764, and CVE-2019-15903. Note: IceCat 68 has not yet been released by the IceCat project. This is a work-in-progress, and does not currently meet the privacy-respecting standards of the IceCat project. * gnu/packages/patches/icecat-default-search-ddg.patch, gnu/packages/patches/icecat-disable-sync.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (%icecat-version): Update. (mozilla-compare-locales, all-mozilla-locales): New variables. (mozilla-locale): New procedure. (mozilla-locales): New macro. (icecat-source): Add code to populate the l10n directory. Remove the code that copied the l10n directory from an older IceCat source tarball. (icecat)[inputs]: Remove hunspell. [native-inputs]: Comment out previous Guix-specific patches for now. Use the newest rust, cargo, llvm, and clang. Add rust-cbindgen, node, nasm, python 3, icecat-default-search-ddg.patch and icecat-disable-sync.patch. [arguments]: In configure flags: remove "--disable-maintenance-service" and "--enable-system-hunspell", and comment out flags to use system libraries instead of bundled libraries for libevent, libogg, libvorbis, libvpx, harfbuzz, graphite2, and sqlite. Add srfi-34 and srfi-35 to modules. Delete fewer bundled libraries. Adapt the 'patch-source-shebangs' phase. Add a custom 'build' phase that tries the standard 'build' phase up to 5 times. In the 'wrap-program' phase, set MOZ_LEGACY_PROFILES=1 in the environment, and add 'pulseaudio' to the front of LD_LIBRARY_PATH. [description]: Add a warning that this is only a preview release. * gnu/packages/patches/icecat-makeicecat.patch: Adapt.
9 lines
417 B
Diff
9 lines
417 B
Diff
--- a/browser/app/profile/icecat.js.orig 1980-01-01 18:59:51.000000000 -0500
|
|
+++ b/browser/app/profile/icecat.js 2019-10-25 06:24:03.065989309 -0400
|
|
@@ -2275,3 +2275,6 @@
|
|
pref("general.buildID.override", "Gecko/20100101");
|
|
pref("general.oscpu.override", "Windows NT 6.1");
|
|
pref("general.platform.override", "Win32");
|
|
+
|
|
+// Disable Firefox Accounts and Sign in to Sync.
|
|
+pref("identity.fxaccounts.enabled", false);
|