mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
a8e149434e
Patches should fix all CVEs reported by `guix lint`: CVE-2015-7747; CVE-2017-6827, CVE-2017-6828, CVE-2017-6829, CVE-2017-6830, CVE-2017-6831, CVE-2017-6832, CVE-2017-6833, CVE-2017-6834, CVE-2017-6835, CVE-2017-6836, CVE-2017-6837, CVE-2017-6838, CVE-2017-6839; CVE-2018-13440; CVE-2018-17095 Since the patches do not reference to CVEs, it's a bit hard to tell which patch actually closes which CVE. Debian reports all these to be closed by the patches below and NixPkgs provides references. * gnu/packages/audio.scm (audiofile): New variable. * gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch, gnu/packages/patches/audiofile-fix-sign-conversion.patch, gnu/packages/patches/audiofile-CVE-2015-7747.patch, gnu/packages/patches/audiofile-CVE-2018-13440.patch, gnu/packages/patches/audiofile-CVE-2018-17095.patch, gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch, gnu/packages/patches/audiofile-Fail-on-error-in-parseFormat.patch, gnu/packages/patches/audiofile-Fix-index-overflow-in-IMA.cpp.patch, gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch, gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch, gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch, gnu/packages/patches/audiofile-hurd.patch, gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: New files. * gnu/local.mk: Add them.
26 lines
845 B
Diff
26 lines
845 B
Diff
From 822b732fd31ffcb78f6920001e9b1fbd815fa712 Mon Sep 17 00:00:00 2001
|
|
From: Wim Taymans <wtaymans@redhat.com>
|
|
Date: Thu, 27 Sep 2018 12:11:12 +0200
|
|
Subject: [PATCH] SimpleModule: set output chunk framecount after pull
|
|
|
|
After pulling the data, set the output chunk to the amount of
|
|
frames we pulled so that the next module in the chain has the correct
|
|
frame count.
|
|
|
|
Fixes #50 and #51
|
|
---
|
|
libaudiofile/modules/SimpleModule.cpp | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/libaudiofile/modules/SimpleModule.cpp b/libaudiofile/modules/SimpleModule.cpp
|
|
index 2bae1eb..e87932c 100644
|
|
--- a/libaudiofile/modules/SimpleModule.cpp
|
|
+++ b/libaudiofile/modules/SimpleModule.cpp
|
|
@@ -26,6 +26,7 @@
|
|
void SimpleModule::runPull()
|
|
{
|
|
pull(m_outChunk->frameCount);
|
|
+ m_outChunk->frameCount = m_inChunk->frameCount;
|
|
run(*m_inChunk, *m_outChunk);
|
|
}
|
|
|