mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-14 19:05:10 -05:00
c7966ba3ef
* gnu/packages/patches/libtiff-CVE-2022-34526.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/image.scm (libtiff)[source](patches): New field.
22 lines
696 B
Diff
22 lines
696 B
Diff
Fix CVE-2022-34526:
|
|
|
|
https://nvd.nist.gov/vuln/detail/CVE-2022-34526
|
|
https://gitlab.com/libtiff/libtiff/-/issues/433
|
|
|
|
Patch taken from upstream source repository:
|
|
|
|
https://gitlab.com/libtiff/libtiff/-/commit/275735d0354e39c0ac1dc3c0db2120d6f31d1990
|
|
|
|
diff --git a/libtiff/tif_dirinfo.c b/libtiff/tif_dirinfo.c
|
|
--- a/libtiff/tif_dirinfo.c
|
|
+++ b/libtiff/tif_dirinfo.c
|
|
@@ -1191,6 +1191,9 @@ _TIFFCheckFieldIsValidForCodec(TIFF *tif, ttag_t tag)
|
|
default:
|
|
return 1;
|
|
}
|
|
+ if( !TIFFIsCODECConfigured(tif->tif_dir.td_compression) ) {
|
|
+ return 0;
|
|
+ }
|
|
/* Check if codec specific tags are allowed for the current
|
|
* compression scheme (codec) */
|
|
switch (tif->tif_dir.td_compression) {
|