mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
d9b8cfd6c6
* gnu/packages/c.scm (aws-c-http): New variable. * gnu/packages/patches/aws-c-http-cmake-prefix.patch, gnu/packages/patches/aws-c-http-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
13 lines
425 B
Diff
13 lines
425 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -7,6 +7,10 @@ endif()
|
|
|
|
option(ENABLE_PROXY_INTEGRATION_TESTS "Whether to run the proxy integration tests that rely on a proxy server installed and running locally" OFF)
|
|
|
|
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
|
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
|
+endif()
|
|
+
|
|
if (DEFINED CMAKE_PREFIX_PATH)
|
|
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
|
endif()
|