mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 11:55:27 -05:00
ef0c65969b
* gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch, gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch, gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.92. [source]: Use patches. [inputs, propagated-inputs]: Update AWS dependencies to Common Runtime. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
11 lines
502 B
Diff
11 lines
502 B
Diff
--- a/cmake/compiler_settings.cmake
|
|
+++ b/cmake/compiler_settings.cmake
|
|
@@ -53,7 +53,7 @@ macro(set_gcc_flags)
|
|
endmacro()
|
|
|
|
macro(set_gcc_warnings)
|
|
- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
|
|
+ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
|
|
if(COMPILER_CLANG)
|
|
if(PLATFORM_ANDROID)
|
|
# when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.
|